Chevy Truck Wiring

Tiny
CHEVYFOREVER1986
  • 1986 CHEVROLET TRUCK
  • V8
  • 4WD
  • AUTOMATIC
  • 146,000 MILES

Vehicle: 1986 Chevrolet K20 Pickup (350/700R4)
Hi everyone, I am having electrical issues with my truck. Tried to start it one day and wouldnt, I noticed the seat belt buzzer was weak and interupted (power to the whole truck acted the same). Replaced the silenoid, solved that problem. Now I can atleast start it, but there is no Electrical power ex: radio, lights, aux. Although it will flicker on and off over bumps, different levels of acceleration and slamming doors? So it never stays on constant but everything works when it does. Thanks for your time everybody!

Do you
have the same problem?
Yes
No
Wednesday, February 9th, 2011 AT 1:03 AM

4 Replies

Tiny
RASMATAZ
  • MEMBER

Start by testing the ignition switch could be heating up and breaking open

Was this
answer
helpful?
Yes
No
Wednesday, February 9th, 2011 AT 1:07 AM
Tiny
CHEVYFOREVER1986
  • MEMBER

Hello, thanks for the reply. Ok, I should add that I have a key broken off in the key cylinder for the past year and a half and its worked fine. I have a replacement just need a steering wheel puller to get it in I believe. Ill look into my manual about the switch though. Thanks

Was this
answer
helpful?
Yes
No
Wednesday, February 9th, 2011 AT 8:40 PM
Tiny
CHEVYFOREVER1986
  • MEMBER

Ok I finally got some time to dig in here and I replaced the ignition switch and installed new key cylinder I mentioned before. Still same situation, power cutting in and out. I have also checked as many wires as I can "see". Anymore suggestions would be great, thanks

Was this
answer
helpful?
Yes
No
Wednesday, March 2nd, 2011 AT 9:45 PM
Tiny
RASMATAZ
  • MEMBER

Inspect and test the fusible links

Was this
answer
helpful?
Yes
No
Wednesday, March 2nd, 2011 AT 10:31 PM

Please login or register to post a reply.

Other Engine No Start Questions