Battery not charging

Tiny
85CJ7
  • MEMBER
  • 1985 JEEP CJ7
  • 4.2L
  • 6 CYL
  • 4WD
  • MANUAL
  • 30,000 MILES
I recently bought a brand new alternator and battery. The old alternator wasn't charging the old battery or the new one. The new alternator also won't charge either.

This is the alternator I bought: https://www.autozone.com/batteries-starting-and-charging/alternator/duralast-gold-alternator/389551_971529_0

This one is a perfect match to the old one: https://www.autozone.com/batteries-starting-and-charging/alternator/duralast-gold-alternator/459962_971565_0

Is that the issue? It doesn't seem likely.

Would replacing the starter solenoid help? Do you guys think it is the wires between the alternator and the solenoid?

I also replaced a piece of fusible link between the starter solenoid and the alternator that had blown. I replaced it with a piece of 14 gauge fusible link. Let me know if there's any other information you need.
Do you
have the same problem?
Yes
No
Friday, January 4th, 2019 AT 7:59 PM

8 Replies

Tiny
CJ MEDEVAC
  • EXPERT
I chopped this out of a 1979 wire diagram.

Do you have voltage at the resistance wire?

Disregard picture 1.

The Medic
Was this
answer
helpful?
Yes
No
Friday, January 4th, 2019 AT 10:45 PM
Tiny
85CJ7
  • MEMBER
How would I check that? It's currently insulated and has a plug in rather than a simple metal contact.

Thank you for your help!

Also, the car starts immediately when the battery is fully charged so I'm not sure if I can check it just while cranking.
Was this
answer
helpful?
Yes
No
Saturday, January 5th, 2019 AT 10:16 AM
Tiny
CJ MEDEVAC
  • EXPERT
I have not forgotten about you!

I've been really busy!

I'll try to get you some diagrams tomorrow.

The Medic
Was this
answer
helpful?
Yes
No
Saturday, January 5th, 2019 AT 7:50 PM
Tiny
85CJ7
  • MEMBER
No worries! Whenever you can, thank you!
Was this
answer
helpful?
Yes
No
Monday, January 7th, 2019 AT 7:10 PM
Tiny
CJ MEDEVAC
  • EXPERT
Okay.

I made you two illustrations

Let me know what your findings are.

That oil you see is from where I pulled out my PCV to show my buddy how much suction it has, unfortunately I tore the grommet off even with the valve cover. They should make them out of vinyl instead of rubber. The pictures I made at night make it look worse than it is, still makes my stomach churn, I get a new one tomorrow and then "Purple Power" away the mess.

The Medic
Was this
answer
helpful?
Yes
No
Tuesday, January 8th, 2019 AT 6:47 PM
Tiny
85CJ7
  • MEMBER
Fixed it! I braided and e-taped the fusible link and wire from the alternator to the starter solenoid but it was making bad contact then came out all together. I couldn't see it cause I had but it back in the clamshell wire harness. I properly put them together with a heat shrink crimp fitting. Thank you for your help and sorry for my stupidity.
Was this
answer
helpful?
Yes
No
Saturday, January 12th, 2019 AT 10:48 PM
Tiny
CJ MEDEVAC
  • EXPERT
Nothing stupid about it!

It's all about learning how to keep your best-us buddy going.

Too many folks take their baby to the stealership or other places when their fix was so simple,

Check out "search" at the top of the page, look at CJ-5 or CJ-7 (the body is the main difference). Maybe something else you see will aid you. Regardless, come back to see us when you need some assistance.

The Medic
Was this
answer
helpful?
Yes
No
+1
Sunday, January 13th, 2019 AT 7:25 AM
Tiny
85CJ7
  • MEMBER
Thank you very much!
Was this
answer
helpful?
Yes
No
Sunday, January 13th, 2019 AT 8:44 PM

Please login or register to post a reply.

Recommended Guides