My Car is running rich

Tiny
NICHISTHEMASTER
  • MEMBER
  • 1985 CHRYSLER LE BARON
  • 120,000 MILES
Hey I have a big problem I have a 85 fuel injected lebaron. It is running way to rich if I can start it there is no power when I put it in gear my mechanic says it is getting 24 pounds of gas pressure and it should get 14. I have replaced the logic module, map sensor, fuel injector, fuel pressure regulator, and I have blown through the return line to the tank nothing has made any diffrence. Please help me I am in need of this car and I dont know what to try now. Thank You
Do you
have the same problem?
Yes
No
Saturday, May 12th, 2012 AT 2:12 AM

5 Replies

Tiny
ASEMASTER6371
  • EXPERT
I would look at the map sensor as it is common along with the fuel pressure regulator for this issue

Roy
Was this
answer
helpful?
Yes
No
Saturday, May 12th, 2012 AT 2:19 AM
Tiny
NICHISTHEMASTER
  • MEMBER
I bought a new map sensor maybe it was no good should I try another one. I have a obd scanner and it came up with code 26 which says fuel injector peak not reached. Thanks for helping me
Was this
answer
helpful?
Yes
No
Saturday, May 12th, 2012 AT 2:53 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If the sensor is bad, try a new one. Keep in mind, you may have a bad wire or something.
Was this
answer
helpful?
Yes
No
Saturday, May 12th, 2012 AT 3:00 AM
Tiny
NICHISTHEMASTER
  • MEMBER
When This happened I could still drive home it just used more gas but now it has got worse. When I blew through the return gas line I unhooked the line at the tank could there still be blockage from there into the tank? Thanks
Was this
answer
helpful?
Yes
No
Saturday, May 12th, 2012 AT 4:19 AM
Tiny
M_H_RITZEL
  • EXPERT
Try cleaning the throttle body out with a cleaner. Have seen some carbon build up and clog the air mixture.
Was this
answer
helpful?
Yes
No
Saturday, May 12th, 2012 AT 3:53 PM

Please login or register to post a reply.

Recommended Guides