1985 Chevrolet S-10 cooling system

Tiny
WILSON5556
  • MEMBER
  • 1985 CHEVROLET S-10
  • 2.8L
  • V6
  • 2WD
  • AUTOMATIC
  • 150,000 MILES
Replaced the water pump and the thermostat but it does not seem to pump coolent past the thermostat.
it will pump without the thermostat but the flow is weak. Someone said it had air traped in the system.
I have never had this problem with any other car. Any ideas?
Do you
have the same problem?
Yes
No
Saturday, November 7th, 2015 AT 2:58 PM

6 Replies

Tiny
ASEMASTER6371
  • EXPERT
Ok, hopefully you replaced the thermostat with a new one after checking. That may be the issue.

What do you mean by weak? It should flow as the water pump moves the coolant. Air is not the issue here.

Roy
Was this
answer
helpful?
Yes
No
Sunday, November 8th, 2015 AT 7:14 AM
Tiny
WILSON5556
  • MEMBER
The themostat is new, I thought maybe it was not working so I tested
it. Works fine. Disconncted upper hose from radiater, started the truck
with the hose held up it barely flowed and that is without thermostat.
It says in waterpump instructions must purge air from system. Never
ran into this problem. Thank you for help.
Was this
answer
helpful?
Yes
No
Sunday, November 8th, 2015 AT 8:04 AM
Tiny
ASEMASTER6371
  • EXPERT
Have you replaced the water pump?

Roy
Was this
answer
helpful?
Yes
No
Sunday, November 8th, 2015 AT 8:27 AM
Tiny
WILSON5556
  • MEMBER
Yes. When I bought the truck it did not have a thermostat in it. Thats what started all this. It runs cool without thermostat but with thermostat installed it overheats. Tested it in hot water, works fine.
Was this
answer
helpful?
Yes
No
Sunday, November 8th, 2015 AT 8:49 AM
Tiny
ASEMASTER6371
  • EXPERT
Ok, someone hid the issue from you when you bought it.

I would have the radiator flow tested to be sure it is not clogged. Make sure there is no dealer in the cooling system as it clogs up the passages.

Have a leak down test done to the cylinders to be sure there is no head gasket damage

Roy
Was this
answer
helpful?
Yes
No
Sunday, November 8th, 2015 AT 8:54 AM
Tiny
WILSON5556
  • MEMBER
Thank you, I thought It may be the radiater.I never heard of air
trapped in the system.
Was this
answer
helpful?
Yes
No
Sunday, November 8th, 2015 AT 9:17 AM

Please login or register to post a reply.

Recommended Guides