1980 Jeep CJ5 not sure whats wrong

Tiny
MIKEPASS
  • MEMBER
  • 1980 JEEP CJ5
  • 4.2L
  • 6 CYL
  • 4WD
  • MANUAL
  • 98,000 MILES
Drove to quick mart got a pop jeep would not start. Was running great when I stopped. Did BASIC TUN UP, no help, back fire through carb and tail pipe. Loud backfire through tailpipe after turning key off. Flooding of gas, gas coming out of top of carb, cought fire. New coil, distributer, roter button, wires, and new plugs gaped to 35. New fuel pump and inline filter, new ignition box (noticed plastic melting out of old). Nothing. Towed it home, pulled timing cover, slack in chain. Replaced timing gears and chain, set to tdc, pulled #1 plug checked with screw driver. Set distributor, finely got to fire but still having major flooding, and fuel coming out or carb. Bought new weber 32/36 carb installed, set throttle linkage, idel screw 2 turns out mixture screw 1 1/2 turns out. Started moter rough idel adjusted idel little more about 1/4 turn out, mixture screw out 1/8 out and started timing. Plugged vacuum advance set distributor tdc got good smooth idle, plugged dist vacuum back reved up timing rose to 8 on acceleration. Got in drove no power, no speed barley get to 35 mph, flat spots in pedal no constant acceleration. What now please help. Im at wits end.
Do you
have the same problem?
Yes
No
Thursday, June 5th, 2014 AT 6:16 PM

10 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi:
The timing should be set to 6 degrees BTDC @ 1600 RPM's. That is with the timing advance disconnected.

NOTE: The engine is equipped with a receptacle for a magnetic probe timing light. Do not use this location to adjust timing with a conventional light.

Let me know. Also, there is a tech here that is a Jeep wizard. Hopefully, he will add his thoughts.
Was this
answer
helpful?
Yes
No
Thursday, June 5th, 2014 AT 7:41 PM
Tiny
MIKEPASS
  • MEMBER
I was using a orileys bought timing light red black clip one clip on #1 wire. Now is 6 % btdc 3 marks on balancer
Was this
answer
helpful?
Yes
No
Thursday, June 5th, 2014 AT 7:57 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Still no power?
Was this
answer
helpful?
Yes
No
Thursday, June 5th, 2014 AT 8:02 PM
Tiny
MIKEPASS
  • MEMBER
Haven't had a chance to work on it since you told me timings. Will get back with you afte work. Thanks for your help.
Was this
answer
helpful?
Yes
No
Friday, June 6th, 2014 AT 5:08 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Glad to help.
Was this
answer
helpful?
Yes
No
Friday, June 6th, 2014 AT 9:15 AM
Tiny
MIKEPASS
  • MEMBER
Ok pulled vacuum advance, bought rpm Guage, brought idel up to 1600 set timing to 6% btdc put vacum advance back on checked timing and balancer mark was on 2% after top dead center or last mark on scale. Idel was around 600 at idel. Burning real rich. Turned idel screw on weber 32/36 back 1/2 turn down to 500and tried to reset idel mixture screw. Its at about 1 3/4 turn. More power still flat spots in second and third gear and almost nothing in fourth. Wondering if maybe compression problem as I noticed jeep will not hold on hill in first gear like it used to. It barley moves ever so slightly backwards.
Was this
answer
helpful?
Yes
No
Friday, June 6th, 2014 AT 6:43 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
You know, I'm a little confused. I'm not sure why the timing retarded when you replaced the vacuum advance. It shouldn't have. It should have stayed at 6 BTDC and under acceleration, advanced beyond that point.

Also, I am starting to wonder if the old carb was dumping fuel which may have partially plugged the catalytic converter. That could explain the power loss. Have you checked that?

As far as compression, that would have to be checked. However, you wouldn't have noticed a power loss all at once. It would have happened over many miles.
Was this
answer
helpful?
Yes
No
Friday, June 6th, 2014 AT 8:03 PM
Tiny
MIKEPASS
  • MEMBER
No. Converter
Was this
answer
helpful?
Yes
No
Friday, June 6th, 2014 AT 8:10 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Okay, that shoots that idea. I hate to ask this, but please check the timing one more time. Watch it while you attach the vacuum advance. It shouldn't retard. I'm sure if the engine is running at 2 degrees ATDC it will cause a power loss. It should be firing BTDC.
Was this
answer
helpful?
Yes
No
Friday, June 6th, 2014 AT 8:17 PM
Tiny
CJ MEDEVAC II
  • MEMBER
I'M NOT GETTING NOTIFIED (HARD TO KEEP TRACK OF POSTS)

ARE WE GETTING ANYWHERE YET?

"MR. JEEP" IS 100% FINE (NEEDS A LITTLE TOUCH-UP PAINT)-"WILLY" (NOT SO GOOD) NEEDS FRONT WHEEL CYLINDER KITS INSTALLED, BRAKES ADJUSTED (I HAVE A POSSIBLE BETTER WAY!), AND BLEEDING.

I'M WORKING ALL OF THE TIME AND CAN'T SEEM TO GET MOTIVATED TO GET 'ER DONE!

SEEMS A LOT EZer TO HELP Y'ALL!

THE MEDIC
Was this
answer
helpful?
Yes
No
Sunday, June 8th, 2014 AT 6:19 AM

Please login or register to post a reply.

Recommended Guides