Why is my edelbrock 650cfm cutting out at wot?

Tiny
SILENT_BOB72
  • 1973 CHEVROLET CHEVELLE

I lose all power at wot.

Do you
have the same problem?
Yes
No
Thursday, September 8th, 2011 AT 3:48 PM

4 Replies

Tiny
DOCFIXIT
  • EXPERT
  • 19,042 POSTS

Fuel pressure good? Float level correct?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Thursday, September 8th, 2011 AT 5:44 PM
Tiny
SILENT_BOB72
  • MEMBER

My mechanical pump is kind of old but pressure seems ok. My float level, I havnt touched. Adjust how?

Was this
answer
helpful?
Yes
No
Tuesday, September 13th, 2011 AT 4:22 PM
Tiny
DOCFIXIT
  • EXPERT
  • 19,042 POSTS

Before tearing carb apart check fuel pressure and flow. 3 to 5 psi and pint in 15 sec

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Tuesday, September 13th, 2011 AT 5:23 PM
Tiny
HMAC300
  • EXPERT
  • 46,997 POSTS

It depends on whether this is a avs styleor afb. I thnk it's an avs style that acarter used way back then. You will have to check the rear blade to see if it's opening to fast, there is or shold be an adjustment on the side for it. Look at your instructions or contct edelbrock i'm sure they have instructions on the net. Or yur metering rod may not be opening all the way. And I dont' remember if it h as a pwer valve or not, those are the ususal causes.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Saturday, September 17th, 2011 AT 7:05 PM

Please login or register to post a reply.

Related Engine Stall Questions

Help us by donating