1970 Chevrolet Chevelle Starting problem

Tiny
VANDERDO
  • MEMBER
  • 1970 CHEVROLET CHEVELLE
  • 165,000 MILES
Hi- 1970 chevelle wagon- 327 motor- started about two months ago- car would start and run and the felt like a surge going through the car- it would start running with less power- stop the car and go to start it- it woulg go like it wasnt going to start or the battery was low then it would start- get to my destination go to start it and dead battery. What could this be?

I took it to firestone hesaid break light switch was the issue nope
I replacethe alternator not that
I replaced the external regulator not that

Battery is good

When I take the cable off the battery with a test light no shorts are showing

Its driving me crazy, any ideas?
Do you
have the same problem?
Yes
No
Thursday, July 11th, 2013 AT 10:29 PM

1 Reply

Tiny
HMAC300
  • EXPERT
Was anything recently put on the car? Checkground from engine to body and body to battery there should be one there. For engine to body it needs to be copper braided wire and to body at least 12 gauge wire. Also check ground to engine from body. Then check your fuel pump if mechanical it should have at least 3.5 psi and 1/2 pint of fuel in 30 seconds at carb. If it's a Rochester 4 barrel it may have a vacuum leak inside carb, very common. Power block magazine from powerblock tv has agood video and article on this in their magazine and it's free just look it up.
Was this
answer
helpful?
Yes
No
Friday, July 12th, 2013 AT 7:06 AM

Please login or register to post a reply.

Sponsored links