1964 Chevy Corvair Spydier 150 hp turbo

Tiny
COCKPIT4HIRE
  • 1964 CHEVROLET CORVAIR
  • 2WD
  • MANUAL
  • 500 MILES

I have a fully restored 1964 Chevy Corvair Spydier 150 hp turbo
She stalls in mid ride a few minutes after start for no reason. New battery.
All power to the entire car goes dead. After a few hours she will start like nothing happened and will drive fine for a few hours or a few days and will stall again.
Sounds like a grounding issue but where?


Do you
have the same problem?
Yes
No
Tuesday, July 12th, 2011 AT 1:04 PM

3 Replies

Tiny
KHLOW2008
  • EXPERT
  • 41,940 POSTS

I don't believe it is a grounding issue, more likely a power supply issue.

A grounding issue should have some components working erratically.

Recheck the battery terminal connections, clean and retighten if necessary. Check the fusible links from battery to main fuse box and from fuse box to the ignition switch.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 3:00 PM
Tiny
COCKPIT4HIRE
  • MEMBER

Thanks! I will check it.
Anyone else has an idea - please let me know!
Thanks guys!

Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 4:30 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,533 POSTS

The ground wire goes to the body in the rear and there is a little wire to the block. Check them for corrosition.

Roy

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Thursday, August 4th, 2011 AT 2:28 AM

Please login or register to post a reply.

Help us by donating