Gas smell, missing on random cylinders and running hot?

Tiny
IPREFERCHEVYS
  • MEMBER
  • 2003 LINCOLN TOWN CAR
  • 4.6L
  • V8
  • 2WD
  • AUTOMATIC
  • 315,000 MILES
My car has recently started running rough missing on random cylinders though five six and one are the most misfired. Also, I can smell gas in the cab when the A/C is running. It's running hot not overheating but running quite a bit hotter than it used to. I replaced the water pump and thermostat thinking that was the issue, it was starting to run hot. That didn't work. Now the cylinders are starting to misfire and I'm getting a slight ticking noise from the valves. Someone told me it might be an EVAP purge valve? But at this point I don't want to throw any more parts at it that's not going to fix the problem. *Edit: it also has some weird smells coming from the engine compartment, has lost a lot of power, AutoZone and my OBDII reader are not catching anything but the codes from the misfires.
Saturday, September 16th, 2023 AT 4:14 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,563 POSTS
Hi,

If you have a misfire, that would likely be the cause of the misfire. However, if you are getting raw fuel into the catalytic converter, it may be plugged or partially plugged. That would certainly cause the power loss.

Do me a favor. Take a look through this link and let me know if there is information that mirrors what you are experiencing:

https://www.2carpros.com/articles/bad-catalytic-converter-symptoms

If you feel there are similar symptoms, here is a link that explains how to check a converter:

https://www.2carpros.com/articles/how-to-test-a-catalytic-converter

Let me know what you find.

Take care,

Joe
Was this
answer
helpful?
Yes
No
Sunday, September 17th, 2023 AT 2:26 PM

Please login or register to post a reply.

Sponsored links