Mechanics

IDLE/START

1997 Saturn SC1

Engine Mechanical problem
1997 Saturn SC1 4 cyl Front Wheel Drive Manual 250k miles

my car has just recently started acting funny. When I go to start it sometimes it takes me 2 times and you can smell gas. Its almost like its misfireing but I just replaced all the spark plugs and cables and the battery. Once I get it started it runs ok until I stop at a stop sign and than the idle drops down to 500 than jumps up to 1000 and keeps going back and forth until I start moving again. It also sometimes dies if I let it sit too long. I have no clue what else I should do to try and fix this problem. The car has a new clutch and slave cylinder new spark plugs and wires and a new battery, my engine is rebuilt I really need help!
Avatar
Shawnlux
September 8, 2009.




Mine is doing the same thing but with so much fuel I cant even start it I think I have it narrowed down to a fuel pressure regulator hope this helps if you have already gat yours fixed id like to now what it was thanks dan

Tiny
Skgreys
Oct 7, 2009.
Sounds like u have a bad coolant temp sensor its screwed in your head below where your upper hose goes on to the head. When the engine is cold you can unplug the connector look at the connector alot of times the sensor leaks into the connector causing in to turn green on the contacts. Also if u were to look at the sensor alot of times the sensor cracks on the side that goes into the head thats why u get the corroded connector. Anyways the sensor is under 20 at the dealer so check it out and let me know what u find.
Louie
AD

Saturntech9
Oct 7, 2009.

AD