Mechanics

SC1 . BATTERY OR ELECTRIC SYSTEM?

2002 Saturn Other

Hi. This is my problem. I got a 2002 Saturn SC1 about 3 years ago. So far so good. No problems whatsoever. But today things changed. I went to a grocery store and when I came back out the car didn't start. Not the radio nor the headlights got on and only the Service Engine light and the Security lights went on on the dashboard. I got the car jump started and it went ok but not for very long. Suddently the needle of the gas started to go down and down and down (which is weird because the car had more than half a tank) and all the other lights went also on on the dashboard. Finally when the gas needle was all the way down the car went off. We jump-start it again and it keep going ok til I got to my friend's house. I tried to start it there and nothing happened. So I got it jump-start it again and it worked again. The guy that put help me out with the jump starting deal said that there was a lot of corrosion on the battery ports and that if I wash them it will help. I will do that tomorrow but I'm getting worried cause I don't know if the problem is only the battery or also the electical system. Can somebody help me out? Do you think is the battery or something else? Thanks.
Avatar
Qayaqpuma
February 19, 2006.




Start cleaning the battery posts and connectors and be sure that its making a solid good connection, that could be your problem.
AD

Tiny
Fisherman
Feb 19, 2006.
I agree with the cleaning the battery and terminals but I would also put a voltmeter on your battery while you have it started to see if you have your 12.5 to 14 volts. If you dont than it is an alternator, or a blown fuse. But you can have the battery and alt. Tested at a local parts store and they can tell you if any are bad or going out. Good Luck!

Tiny
Nick decock
Feb 28, 2006.

AD