Mechanics

OLDS DELTA 88

1985 Oldsmobile Other

Need help please, 1985 olds delta 88, 350 v8 auto 85000 miles. My neighbor was driving down the road and his car went dead in the middle of the road. The battery is new and the headlights are bright when on but there is no power to the ignition switch when you turn it. Nothing happens at all. We pulled it home. Can anyone tell us what may have went wrong? Thank you very much. Ralphie
Avatar
Ralphie
January 25, 2007.



Try putting it in nuetral and cranking it.

Thank you for your reply, We tried to crank it in neutral, nothing happens. When you turn on the headlights and turn the switch it doesn't affect the headlights at all. No lights on the dash or anything. Any thoughts. Thank you. Ralphie

Tiny
Ralphie
Jan 25, 2007.
I would suspect one of two things. Ignition switch or a bad connection. IF you checked for any loose or corroded connections from the battery to ground, to the starter etc.

Check all your fusible links. When you turn the key to On, again do you see any panel lights

Rasmataz
Jan 26, 2007.
Thank you both for your replies, it was dark and 20 degrees when it broke down so we will check out your suggestions today and report back. And for the record there are no lights on the dash when you turn on the switch but the headlights work ok and turning the switch on and to start position has no effect on anything. Thanks again, Ralphie.

Tiny
Ralphie
Jan 26, 2007.
Checked the wires going to the starter and of the two small red wires one of them is broken where it goes around the starter guard, which is loose and I guess it vibrated so much it broke the wire. We're going to repair it and hope this is the problem. Thank you all for your help. Ralphie. Man it's cold out there.

Tiny
Ralphie
Jan 27, 2007.
Get that baby going and you'll be warm and cozy.

Rasmataz
Jan 27, 2007.
Update us!