Mechanics

LOW GAS MILEAGE AND HARD TO START AFTER

2001 Honda Passport

Engine Performance problem
2001 Honda Passport 6 cyl Four Wheel Drive Automatic 127000 miles

I have replaced the timing belt, fuel pump, spark plugs, air filter, EGR valve, and temperature sensor. The engine starts easily when cold. (Check Engine light stays on or flashes off and on when accelerating). After warm up engine is hard to start without lightly pressing the accelerator and lopes at idle occasionally shutting off. I have figured the gas mileage at 13mpg. What can cause these problems and how can they be repaired?
Avatar
Jflow53
October 27, 2009.




Hi jflow53 and TY for the donation

Just by the CEL coming On and Flashing is an indication of a problem within the engine management system. Go to Autozone and get scanned its a free service this will ID where its coming from and get back with the code/s asap

Could very well be an idle speed controller/valve/motor problem to include the throttle position and mass airflow sensors-or a fuel pressure problem.

Tiny
Rasmataz
Oct 27, 2009.
The trouble codes for the check engine light are P0160 and P0161. What can correct this problem? Will correcting it stop the poor gas mileage and starting problems?
AD

Tiny
Jflow53
Oct 28, 2009.
Those codes are for an oxygen sensors-might be on the lean condition and not switching and computer throwing fuel at it due to its reading lean.

Starting problem could be the caused by a coolant temperature sensor not telling the computer to enrich fuel demand during cold starts before the oxygen sensor goes into closed loop to control fuel mix and also low fuel pressure.

Poor gas mileage can be anything within the vehicle sub-systems.

When the last time it was tuned-up? Maybe you should consider getting it tune.

Tiny
Rasmataz
Oct 28, 2009.
What else is there to replace for a tune-up? I replaced plugs, air filter, coolant temperature sensor, fuel pump with filter, cleaned throttle body. I understand timing is not adjustable. Cold starts aren't much of a problem only when warm.

Tiny
Jflow53
Oct 28, 2009.
Try cleaning out the mass airflow sensor and the EGR valve and test the throttle position and manifold absolute pressure sensors-

Tiny
Rasmataz
Oct 28, 2009.

AD