Mechanics

MODELS

1990 GMC Other

Engine Performance problem
1990 Other GMC Models V8 Four Wheel Drive Automatic 217000 miles

I have a 1990 GMC Z71 4X4 with a 350 TBI 217K my problem that I cannot figure out is after giving the truck new plugs, wires, cap, rotor, coil, TPS and vac. Line, O2, Map sensor and vac. Line, air cleaner gasket, fuel filter--NO EGR on motor. The truck just doesn`t want to go once it hits second and will burp through the TBI leaving the truck with very little power getting to speed. Had timing check by a local and said it was off 3- degrees, returned it back to 0, and truck ran worse. I can hear the fuel pump kick on and is my understanding that either they work or they don`t. I don`t have any problems starting the truck and does not die when stopping, but will maintain a higher idle at stops and when put back into park. After the truck is at temp, to restart the truck will bring idle down until driving starts again. What more can be done to make me a happy man to a happy motor. And is there a safe way to lift a motor when you do not have a engine hoist. Hopefully someone can help.
Avatar
K Gee
May 10, 2010.




Check to see if the TBI gasket is leaking, they do that quite a bit. Spray choke cleaner around the base and if the idle changes it's leaking. Then put a vacuum guage on it and if the vacuum is around 15" at idle thencheck for a plugged catalytic converter. You can get replacement converters for around $75 on ebay, they aren't factory, but will work.

Hmac300
May 26, 2010.


AD