Mechanics

LOW OIL PRESSURE PLEASE HELP

Dodge Ram

01 DODGE RAM 1500 5.9 4X4

I AM HAVING A LOW OIL PRESSURE PROBLEM WITH MY TRUCK, FIRST OFF I AM AN ASE TECH SO I KNOW WHAT I AM DOING, SO ANYWAYS IT HAS LOW OIL PRESSURE AT IDLE AFTER ENGINE IS WARM, SO I WENT TO CHANGE THE OIL PUMP, IT ALLREADY HAD AN AFTERMARKET HIGH VOLUME OIL PUMP IN IT, THE SAME ONE THAT I BOUGHT, BUT I PUT THE NEW ONE IN ANYWAYS, STILL LOW OIL PRESSURE, SO I CHANGE THE SENDING UNIT, WITCH WAS LOOKED NEW, SAME LOW OIL PRESSUERE PROBLEM, AND ALSO I HAVE WHAT SOUNDS LIKE A SLIGHT LIFTER NOISE ABOVE 3K RPM, LIKE THE LIFTERS ARENT PUMPING ALL THE WAY UP, SO I PULL OFF THE VALVE COVERS AND CHECK ALL THE PUSH RODS, ALL ARE CLEAN AND I PERFECT SHAPE, THEN FINNALY THE VALVE CLATTER HAS GOTTEN A LITTLE WORSE AND NOW I HAVE A CYLINDER 1 MISFIRE CODE, SO NOW IM ALMOST SURE IT IS THE LIFTERS NOT PUMPING UP, BUT WHAT I DONT UNDERSTAND IS WHY IS THERE LOW OIL PRESSURE AT IDLE BUT WHEN ABOVE 1K RPM IT HAS 100PSI WITH THE HIGH VOLUME PUMP, AND NO ITS NOT BEARING CLEARNCE ALL BEARINGS ARE IN PERFECT SHAPE AND ARE NEW, I DONT UNDERSTAND WHAT TO DO HERE I WAS GOING TO CHANGE ALL THE LIFTERS BUT I DONT KNOW IF THAT WILL SOLVE MY LOW OIL PRESSURE PROBLEM OR THE VALVE CLATTER, AND NO ITS NOT SPARK KNOCK, ANY HELP PLEASE? THANKS -DANIEL
Avatar
Atl0369
November 16, 2006.




Not sure if this will help but I have a 94 with a 318, 80,000 miles, and I am having the exact problem except no noise. I have found that after a oil change I am good but after about 1 month of light driving I get the oil light flashing as the rpms get lower and the pressure gauge starts jumping around down to nothing and back up at idle. When the rpms get back up everything is good. I checked the oil and the oil was actually about a quart or more over. This has happened several times and know for sure it wasn't overfilled. Noticed a very gassie small to the oil. Now mind you the vehicle sat for about two years after this starting happening because I had bought a new truck. After I ended up going to a car I decided to get the Ram back on the road. After changing the oil pump, O2 sensor, and oil sending unit I still get the same thing. Check the oil level everyday and it steadily gets higher, so I know I am getting gas in the oil some how. Checked the injectors for leaking after shut off and no leaking. I am now totally stumped and I have always repaired my own vehicle and consider myself a very good backyard mechanic. Didn't mean to be so long but is it possible that you could have the same thing, check the oil.

Tiny
Bear300t
Nov 16, 2006.
Umm to answer the guy with the fuel smell ive been told it the fuel regulator. As far as the low oil pressure, im not sure could there be a clog in one of your push rods, have you tried a different weight of oil, when you took the valve covers off did you check that the push rods were actually sending enough oil up through them.
AD

Tiny
1bigg1
Nov 17, 2006.

AD