Mechanics

CHEVY ABS, ENGINE SPUTTER, CODE READER CONNECTI

1995 Chevrolet Blazer

1995 Chevy Blazer 6 cyl Four Wheel Drive Manual 150000 miles

I have a 95 chevy blazer 4.3 vortec v6. The engine check light is on. Abs light comes on after 10 or 15 mph is reached. Abs started after changing brake pads. Brake cylander seemed a little hard to compress back in to fit pads over rotor and had to release bleed valve to get pads over rotor with a c-clamp on driver side. 2nd problem check engine light has been on for months. Did not pass emissions first time untill replacement of O2 directly in front of cat converter. Then replaced exhaust pipe and cat converter. Check engine light still on. One week ago engine started chugging when foot not on pedal, stop light/siign/idle. Changed plugs, wires, cap, rotor, feul filter, and throttle position sensor, and feul pump is only a year old. Funny though. Does not chug when throttle position sensor is disconected. Just runs at high idle and thunks into gear, but no thunk into gear when tps is plugged in. 3rd problem, I cannot get any code reader to read code. I've tried 3 differet obd 2 code readers and get " unable to establish link" " shucks" and " harbor freight" obd 2 reader and code read error " MAC' obd 2. Fuses are all good. Noticed also coolant levels drop sporadically. Estimated 1 gallon every three- four weeks.
Avatar
Wickedsickkix
December 13, 2009.



First start with the abs, check the speed sensor on each wheel. Check the electrical connections to make sure they have a good contact. Check the backing plate for the speed sensor to make sure it is not broken or bent. You can try some throttle body cleaner, there may be a little build up of carbon inside the throttle body. To reset the engine light you can try by disconnecting the battery for a minute then reconnect it. On some vehicles the computer will not reset until it is driven about 50 miles. If the light then comes on check it with the scanner.

M_H_RITZEL
Dec 14, 2009.
New fuel pump, new egr new instake set, new plugs, wire cap and roter. All the vehicle will do is idle. After intake and tune up the fuel pump started shutting off. Replaced and drove for about 2 miles fine. Then it threw an egr code. Replaced egr and now it will not run over 1500 rpm. I am at a loss and there is now no codes

Tiny
Mattstrandberg
Apr 15, 2012.
Make sure everything has been installed and connected properly. Make sure nothing is leaking.

Rivermikerat
Apr 18, 2012.