Mechanics

HEAT/ AIR BLOWER PROBLEMS

2002 Cadillac Escalade

Heater problem
2002 Cadillac Escalade V8 All Wheel Drive Automatic 110000 miles

My rear heat and air seems to work just fine but the front doesn't work correctly all of a sudden.
In the front I can feel just a small amount of cold air or heat but not the full force like usual. It seems like a blockage or something. I can hear and feel a change with the venting as I change from floor to defrost but hardly any air comes out. Also I hear the blower motor run faster and slower as I change the speeds.
Do you have an idea as to a solution?
Thanks
Gary
Avatar
Gwsheets
September 16, 2008.




You may have a plugged cabin filter if themotor is changing speds. Remove the plastic shield on pass side inder dash


http://www.2carpros.com/forum/automotive_pictures/1639_caddy1_1.jpg



then remove the retaining screw and remove the cover for the filter


http://www.2carpros.com/forum/automotive_pictures/1639_caddy2_1.jpg



see if it is plugged or slowing down air flow.

Tiny
Jack42
Sep 17, 2008.
Thanks! I got the shield off now there are sone wire clamp screws but not a set screw that I see anywhere.

I cannot find the mentioned set screw and how does the cover remove after I take out the set screw?

Tiny
Gwsheets
Sep 21, 2008.
Try removing those screws. After removed, the cover should pull down out of the way. See pic

Tiny
Jack42
Sep 22, 2008.
I guess you don't understand what my question was. My fault.
The screws were removed from the shield and the shield was removed. Per the picture.
I don't see the mentioned set screw anywhere. I don't see the set screw in the picture either. The wire clamps dont seem to have anything to do with removing the filter cover itself.
How do I remove the filter cover? Please refer to the picture that you sent. I don't think it is complete information.
Thanks
AD

Tiny
Gwsheets
Sep 22, 2008.
Sorry, that is all the info I have from my software. It covers from 99-02 models. I looked it up for all of them and it is the same. There is a screw holding the cover in and 2 filters inside. Mitchell doesnt mention the exact location of the screw, just that it holds the cover on. It is possible they are wrong and the cover just pops out, with out seeing the vehicle I cant tell you which it is

Tiny
Jack42
Sep 26, 2008.

AD