Mechanics

ABS/ESC LIGHT CAME ON

2007 Kia Sorento • 58,600 miles

This afternoon I started my SUV and noticed the ABS/ESC light came on and I just kept driving I live about 15 to 20 mins out of town and from the dealer. It drove fine Until I came to the first stop light and then it started running rough and stalled. I restarted it and and ran fine till I put it in DRIVE then it stalled again so I had to drive with the gas/brake until I got to the dealier. They hooked up to get the codes and the only one that showed up was speed sensor RT. Rear. He cleared the codes and we tried it again. Runs fine when in park but put it in Drive it dies! My tech Sorry to say does not know what to do. I tried turning the A/C off and it runs fine. Once a/c is turned on it stalls. I need help the Dealer sucks here on my Island (hawaii) and I would have to drive 100 miles to get to the other one on the other side of the island. Please help.I would go some where else to have it repaired but I still have the warrenty. And I cant spell either.


Avatar
Makala39
October 11, 2011.



As far as the sensor, it sounds like it needs replaced. A wheel speed sensor will trigger both the ABS and ESC light to come on. As far as the idle issue, have him check for vacuum leaks as well as check the idle air control valve. Before paying for the IAC, have him check the warranty on emissions components.

To tell you the truth I really dont have much faith in the Tech but I will ask him and have him check didnt think about a vacuum leak. That could also be the cause of another problem I have been having. A rotten egg smell at times and its not the battery. He cant seem to find that problem either. I put some STP in it 2 weeks ago and have not smelled the rotten eggs at all. I hope by doing that I didnt cause another problem. Thank you so much for your advise.

Tiny
Makala39
Oct 11, 2011.
What was the EXACT trouble code retrieved?

Try checking the Engine Control Module connections. Look out for contaminations.

KHLow2008
Oct 11, 2011.
Don't worry, the STP won't hurt anything. As far as the smell, that is a common odor from the catalytic converter.

The tech deleted the code before I could see it the tech used to work with for me before I wa his service manager so he cleared the codes before I hot to read then and for the cat smell I'm not losing any power and it doesn't set a code.

Tiny
Makala39
Oct 11, 2011.
That doesn't surprise me. They can put off an odor and be fine.

They just want to shut up the customer so I'll just keep buying them until itthank you for your help I'll see what they find today s repaired

Tiny
Makala39
Oct 12, 2011.
Let me know what they tell you. I'm interested in hearing what they have to say.

They didn't have time to look at it today and they say they can't hear a vacuum leak I said they should use carb cleaner and they looked at me funny I remember old school they used to do that. I'm almost ready to pay to go somewhere else they still think I'm nuts and blow smoke up my. About the smell. I just want the damn thing fixed right and not half a.

Tiny
Makala39
Oct 12, 2011.
I understand your frustration. As far as the carb cleaner, it's still used today. Just have a fire extinguishier near by incase there is a flash fire. I do it all the time.

Page 1 of 2