Mechanics

VACUUM LEAK?

2003 Ford Expedition • 138,000 miles

2003 expedition, has had catalyst codes for awhile, as well as bank 1 and 2 too lean. Nasty smelling exhaust, jumps while idiling at drive through etc from 500-1000 rpms, gas mileage sucks. Also has humming noise from deep in engine compartment. Shop thinks they found vacuum leak and are replacing purge solenoid, want to make sure this is truely it and im not being taken for a ride, could this really be as simple as that. Thoughts?

been told by several shops need to replace engine, this guy says not the case, quite often mistaken for needing engine replacement
Avatar
Emt_linz7
March 2, 2012.



Lean fuel condition could be caused by one of the following below: 1. Vacuum leaks

2. EGR and PCV valve.

3. Low fuel pressure.

4. Dirty fuel injectors.

5. Mass Air Flow Sensor.

6. Oxygen Sensor.

Rasmataz
Mar 2, 2012.
So could changing out the purge solenoid be the fix?

Tiny
Emt_linz7
Mar 2, 2012.
What are the exact code/s?

Rasmataz
Mar 2, 2012.
I dont remember numbers now, I think p0420 was for catalyst, not sure of the bank 1 too lean and 2 too lean codes

Tiny
Emt_linz7
Mar 2, 2012.
Have the catalytic converter and oxygen sensors-checked/tested

Rasmataz
Mar 2, 2012.
Yes, spent $85 getting those checked by exhaust shop. Said nothing wrong. Egr valve has been replaced, spark plugs, a vacuum line, 1 o2 sensor and 1 converter.

Tiny
Emt_linz7
Mar 2, 2012.
Check the rest on my 1st suggestion and then comeback with results

Rasmataz
Mar 2, 2012.
Were you able to find a solution, as I have similar problem and have tried same things and stalling still occurring.

Tiny
Rcfoote19
Apr 19, 2012.