Mechanics

CHEVROLET IMPALA RADIO PROBLEM

2003 Chevrolet Impala • 100,000 miles

Hi, my car radio on my Impala works fine, but no sound comes out. I don't know how to explain it. I just checked my fuses, its not that. I just got my license, so I know nothing about cars. I was hoping this is something I could have a family member fix. HELP!
Avatar
Jessicuhhxscanz
December 26, 2011.



Have you tried pulling the radio fuses for ten mins and put them back in to see if that resets the radio?Sometimes the radios and other electronics get logic locked.

Saturntech9
Dec 26, 2011.
I think it has to do with the speakers themselves, not so much the radio. The readio itself works fine, its the sound.

Tiny
Jessicuhhxscanz
Dec 26, 2011.
I think it has to do with the speakers themselves, not so much the radio. The radio itself works fine, its the sound. Plus, im not sure which one is the radio fuse. I just assumed the one that said "cig/aux" on it was the radio one. Nothing on the panel says radio.

Tiny
Jessicuhhxscanz
Dec 26, 2011.
Your not understanding logic lock its like when your smart phone locks up or doesnt do certain functions and you have to turn it off to reset it. Do have a factory radio or aftermarket?Also if its factory does it have a amplifier?

Saturntech9
Dec 26, 2011.
If by factory, you mean it came with the car, then yes.

Tiny
Jessicuhhxscanz
Dec 27, 2011.
Alright is it the radio with the factory amp or the one without?Let me know so I can help you out.

Saturntech9
Dec 27, 2011.
Uhm; I know nothing about cars. Haha. Whats a factory amp?

Tiny
Jessicuhhxscanz
Dec 27, 2011.
A facory amp would mean you would have a seperate amp that is factory. It would be in the luggage compartment beneath the center of rear package shelf.

Saturntech9
Dec 28, 2011.