Mechanics

CHEVY Z71

2000 Chevrolet Tahoe • V8 4WD Automatic • 88,000 miles

I have a 2000 chevy tahoe z71 small issue when driving cold it accelerates fine when ir warms up it sounds like it reves up high but my tacmeter doent show that it is reving amy higher than it should it just sounds most noise coming from engine compartment like I said it runs fine cold but not warm 5.7 liter vortec what could cause this
Avatar
Kadin123
June 12, 2011.



When warm and the engine revs (and the tach doesn't), does the vehicle still accelerate normally or does it miss, lose power, anything out of the ordinary?

It does not have the same power as it does when cold it sounds more like a fan speed up it does not sound like a vortec rev it is not a knock or

Tiny
Kadin123
Jun 12, 2011.
Thanks for your time and help hope you can help me more

Tiny
Kadin123
Jun 12, 2011.
Can you tell me if the check engine light has ever come on?

Not since I had it no and it does not get hot do you think it could be trans or vacum leak

Tiny
Kadin123
Jun 12, 2011.
This is a tough one to call because the loss of power but the engine sounds like it is reving. I will tell you that these vehicles had a lot of trouble woth the insturment panel. They go bad. It almost sounds like the trans is slipping. Is the trans fluid clean?

Not sure will check and get back with you if it is not I will change and see if that helps thanks for all of your help and time just want to get a second opinion or a good anwser thanks

Tiny
Kadin123
Jun 12, 2011.
Let me know.