Mechanics

SATURN SL2 ALARM SYSTEM PROBLEM

1999 Saturn SL2 • 181,000 miles

Recently, my Saturn SL2 has had trouble starting. The alarm system was added after it left the factory and before I took it home new. After replacing the horn three times, the horn was was moved to under the dash and was disconnected from the alarm system. The alarm system still works, enough to disable the starting system, even though there is no audible alarm. Recently, the car was disabled when I tried to start the car, but I was able to start it when I pushed the door unlock on the fob. This has happened several times; two times the engine must have been dead - the clock reset to 12: 00 and radio station presets were gone. Tonight, the fob worked to open the doors, but would not work when there was no ignition. There were no lights or clock. The fob continued not to work, even though I replaced the battery (twice) with fresh batteries. The auto door locks did not work. Periodically, the lights and auto door locks would work and the overhead light would flash, but the car would not start. How can I continue to use the car? With a 13-14 year old car with 181,000 miles, I am not as concerned with the alarm system as continuing to drive a car that has been truly reliable.
Avatar
Guest
December 22, 2012.



The alarm was added after it left the factory?If so it has to a aftermarket alarm. I never have seen a factory add on alarm for that car. Also have never been asked to install one.I have worked for saturn for 16yrs so that would be a first for me. Please post a pic of your alarm remote.

Saturntech9
Dec 23, 2012.