Mechanics

HEATER CONTROL SOLENOID

1999 GMC Suburban • 145,000 miles

Hi, I am asking this question again because I have new details to my last question, and please ask that another tech answer for me. The solenoid has two wires going into it and two vacuum hoses at the top of it (one going to the hcv).I have ruled out the heater control valve being bad. I have now ruled out the solenoid itself being bad because I applied 12v to the black/grey wire and the solenoid clicks and allows vacuum to the hose, thus moving the hcv lever to move. Now, I have two heater controls in this suburban, one in the front and one in the passenger area. My question is why is it not getting power. I have checked all the fuses in the cab and the engine area and all were good. What could cause this connection not to get power? Any help is greatly appreciated. Does anyone have a wiring diagram for this? Thank you. Dave.
Avatar
Dcplace2007
October 16, 2011.




Check the relays for the HVAC system.
What submodel of Suburban is it? C1500/2500/etc? I need this info in order to get the correct schematic for you.


Rivermikerat
Oct 17, 2011.
Dang. Sorry rivermikerat. It is a 1999 GMC Suburban K1500 4x4, 5.7L 350 Engine, "R" Vin. Hope this helps. Thanks so much for your help.


Tiny
Dcplace2007
Oct 17, 2011.
Yep. Twas exactly what I needed. Here are the schematics. Let me know if you need any help locating any of the components.


Rivermikerat
Oct 18, 2011.
Thanks a bunch.I will take a look at them.
AD


Tiny
Dcplace2007
Oct 18, 2011.
I was wondering how to enlarge them. I saved them as a picture, but when I blow up the print, I can see what is written.


Tiny
Dcplace2007
Oct 18, 2011.
Ok. Try these. They are the original pdf docs I converted to jpg images.


Rivermikerat
Oct 18, 2011.
Download the files and change the extensions to pdf.


Rivermikerat
Oct 18, 2011.
Hmmm. That didnt work either-not sure what why it is not working. The waiting symbol continues rotating but no picture appears. Is it possible for you to email them to me?


Tiny
Dcplace2007
Oct 18, 2011.
Yeah. I can do that.


Rivermikerat
Oct 18, 2011.
Thanks. What is happening is that many pictures that come up have that dreaded "x" on the upper lefthand corner.I am not sure how to change that. It might be my firewall, or a setting that I have to change in IE.I will try to figure it out. I think the only way I can receive certain pictures is through email.


Tiny
Dcplace2007
Oct 18, 2011.

AD