Mechanics

MY 205GTI 1.9 IDLES BUT WONT REV

1997 Peugeot 205 • 823,423 miles

I have a 205gti 1.9, it starts so well, idles perfectly but when I try reving it cuts of, or even some times revs roughly and cuts of, what could be the problem?
Avatar
Illy
October 11, 2011.



There are a few possibilities and things you can check; Catalytic converter could be cloged. Check entire exhaust system for restirctions or glogs.
Check fuel pressure.
Check the air passage for dirty or clogged air filter and anyting else that might clog air flow.
The ignition coil could be weak or failing, test it and see if it is putting out proper voltage. I do not have any specifications on your car. It should have 12V to the coil, but I am not sure of the output which should be in amps or millijoules.
Check the spark plug wires and the spark plugs.
The EGR valve may be stuck open. It is near the throttle body. It will have a vacuum connection that should allow it to opem amd close when you remove/attach it. If it does not, try cleaning it, but be careful and gentle as the diaphragm may get damaged.
Cechk charging system, for a 12V system it should be between 11 and 15 volts.
Check Mass Air Pressure, or you may have Air Intake Temperature sensor.
Check the timing as a worn out belt or/chain could skip a tooth and cause this issue.
Check the vents on the laternator to make sure they are clear as this will cause it to overheat.
Check camshaft lobes for signs of damage or worn out lobes.
Check batterry cables and make sure they are not corroded and are a tight fit. Check at the battery and where the positive goes to the starter/solenoid and the negative goes to engine block.
Check distributor for wear, loose bearings, etc.
Check computer for good connections and corrosion.
Also check accelerator cable to make sure it is opening the throttle boddy fully.

Let me know how those things check out and we will be here to help walk you through diagnosis further. I wish I had specificatiosn for your vehicle, but it is not listed so I assume it is a european only release.
I will do the best I can and be here to walk you through any process that you have questions about.

Have checked all this possibilities every thing is ok, but still cant rev, but the spark plugs run too rich

Tiny
Illy
Nov 1, 2012.
If it is an EFI type system maybe one or more of the injectors are bad. The seals can go bad and they will alllow tooo much fuel into the combusiton chamber. Make sure the fuel pressure is at its specified PSI, or that will cause problems too if it is too high.
So check the fuel presssure and make sure it is at specification. The fuel pressure regulator could be bad, I looked up the part number, it is 605133390.
Your car shares a lot with the 1.9 gti. I looked in several places and found that people with the same problem had bad injectors or air flow meters.
So, I think if fuel pressure is okay, then the next step would to rebuild or replace your injectors. There is a place called RC Engineering which you can look up on the internet. They will take your old injectors and rebuild tham and balance them and give you a printout of each injector to show its flow and then you can determine which cylinder to put the injector in by usining the best compression of each cylinder. The Higher the compression, the higher the flow rate of the injector that you should instal on that cylinder.
I hope this helps you out. I think making sure the fuel pressure is set correctly and that your fuel pressure regulator is working is very important. Do that before you do anything with the injectors. After you have set the fuel pressure and are sure the fuel pressure regulator is working right or have replaced it, then see how the car runs. You may not need to replace or rebuild the injectors if this fixes it. If it still runs rich, then you should consider replacing or rebuilding the injectors.
Let me know how it goes. It sure has been a long time since you last posted to this question. Over a year.

Thanks so much for your help, I changed the fuel regulater, and the injectors, know the car starts well but wont rev, and when it revs, it revs roughly and a lot of backfires, another oroblem have noticed when it warms up thats when it starts the problem, am so stressed.

Tiny
Illy
Nov 9, 2012.
I am going to give you a walk through diagnosis for your situation. Just use the link below to get to the diagnosis;

http://www.2carpros.com/articles/engine-misfires-or-runs-rough