Mechanics

ENGINE STARTS MISSING AFTER IT WARMS UP

1996 Nissan Skyline • 156,000 miles

My car starts missing after it warms up. When i'm stopped and leave it in drive the engine will drop about 200rpm then rise back up to 650rpm quickly and it does it every few seconds and if I put it in neutral or park it may do it once or not at all, when I take off it hesitates between 2000 to 3000rpm, I recently replaced the spark plugs thinking that will solve it. The coils (there is one for each cylinder so 6 of them) seem to be in good condition and they weren't hot when removing them (i had to drive it about 15 minutes to a friends house) to put the new plugs in and no sign of any cracks and the wires leading to them are all in good order. I replaced the fuel filter at about 145000 miles and air filter and oil change and oil filter at 155000. I noticed that there is a split in the blowby hose that goes between the two cam covers and the air cleaner, so please any ideas of what the problem is. It's been doing it since about 150000 miles but it doesn't seem to be getting worse
Avatar
Rocko1982
January 1, 2012.



Is the MIL ibndicating and have you tried to check for trouble codes?

Is it misfiring or just erratic idling?

Misfiring between 2-3 k rpm could be due to a fault with the EGR system if equipped.

KHLow2008
Jan 1, 2012.
It's not making any popping noise's it just drops the revs for a split second so I don't think it's misfiring I used to own a car that misfired but it's not doing the same thing also there is no warning lights showing when it doe's it. It's more erratic idling. I think that hose that has the split may be part of the egr system so i'll replace that and see what happens

Tiny
Rocko1982
Jan 1, 2012.
Have the IAC and throttle body cleaned. They would cause erratic idling when air ppassages gets dirty and partially bklocked.

KHLow2008
Jan 1, 2012.
Fixed the problem, turned out it was a split vaccuum hose that ran between the two cam covers, now it's sweet as also checked the hoses leading to the throttle body and cleaned them out, now it's like driving a new car and has a lot more get up and go

Tiny
Rocko1982
Jan 2, 2012.
Glad to know you have fixed the problem.

Have a great day.

KHLow2008
Jan 2, 2012.