Mechanics

CHECK ENGINE LIGHT 25,26, AND 71.

1995 Toyota Camry • 257,000 miles

I already replaced of new Distribtor system, ECU, MAP, Idle control solenoid, coolant temperature sensor, spark and spark wire, ignition module. Anyway, my car seem no good idle and misfire, but it drive as speed very good after blue smoke gone few second (valve stem leaks bad). So, how do I test the fuel injection, 1 heat oxygen sensor and 2 oxygen sensor? I allways looking for scanner test. But 1995 Camry had no scanner of OBD2 plug, it a Diagnostic system not easy way to test. It like no reading live Data information, only trouble read code. I hate that, and I can't find clue of engine idle rough still.
AD
Avatar
Iancarvalho
October 3, 2012.




Happy New Year, And I really so upset of my car Camry not getting better at all, funny. I replaced new VSV control, EGR gas temp sensor, and EGR Modulator. It seem that I found out the engine stalling after stop on the road. So, I pull over the side road for checking out, that I pull off the vacuum hose on top EGR Valve sound like hold so enough, then I heard vacuum air release of EGR start close. "Pop!" I drove again same thing stalling second time, Remove hose of EGR Vacuum to release sound, "Pop again!" So, I don't use EGR Valve without vacuum hose. I drove on the road till no stall, back home at park alot. I believe the VSV system not working property, something not right with ECU. These car still misfire at idle engine running, but high speed or racing still good on the highway with no EGR vacuum that EGR still close all days. I wonder the engine problem.

Tiny
Iancarvalho
Jan 5, 2013.
Check the VSV hoses installation. Reversed installation of the hose can result in vacuum not releasing after the solenoid is activated and released.

KHLow2008
Jan 6, 2013.
Okay, the VSV was a wrong line to reverse of connection to EGR and back around from Modulator line. EGR seem working better. But I drove the car few minute seem cause the engine stall so bad on the road. Then back home without EGR line again. I found ASV Valve air leaking louder, never heard before. It falling part, that rare part I ever heard for air condition idle-up valve replaced. Then again code 41 came out engine light. It was very low idle less then 700 rpm. Because replace ASV Valve. I move TBS for little more idle run about 900 rpm. So, it pretty misfire weird few second at warm and some time engine stall at stop traffic with EGR.

Tiny
Iancarvalho
Jan 18, 2013.
Hello guys. My car had a little trouble of erratic idling again many time after stop traffic light on the road. One day, the engine light code came out 41. It a TBS trouble again. I don't know how I doing for these test. I already replaced TBS sensor. But it doing same problem of code 41 again. Sometime engine stalling and erratic funny.

Tiny
Monicacarvalho
Feb 3, 2013.
When was the TPS replaced?
Were the wires and connectors checked?

KHLow2008
Feb 4, 2013.
TPS was replaced last 1 mouth and connection plug look fine. I don't know of what is cause. So, I will check the wire from TPS's end connection plug to ECU Black box terminal.

Tiny
Iancarvalho
Feb 4, 2013.
Let meknow how it goes.

Btw was the TPS adjusted correctly?

KHLow2008
Feb 4, 2013.
The book said, Using an ohmmeter, measure the resistance, between the indicated terminal pairs a (0.028 in.) Feeler gauge between the throttle stop screw and lever, and connect the ohmmeter to terminal IDL and E2. So, I don't know what is mean "Infinity" reading for ohmmeter resistance. It about the idjusted.

Tiny
Iancarvalho
Feb 4, 2013.
Infinity means there must be resistance shown and not zero.
AD

KHLow2008
Feb 5, 2013.
Okay, I adjust the TPS is okay and I found out that I have timing light for reading rpm very low at 556 rpm. That book say must be 750 rpm with jumper terminals E1 and TE1 on the SST test connector. I adjust the stop level screw for read 755 rpm. So, that reason of rpm very low, that cause the engine stall with EGR on. Now, EGR work much better with engine idle but for awhile few minute again. It feel like again, the engine idle miss few second more then smooth, it like missing three times and then no missing, and few 5 second missing three time or less. It very wierd and no clue of where this come from. All I do everything check look fine and no engine light code at yet. My wife try tell me, "Maybe fuel filter need to change for now". I told her, " I got a test fuel gauge reading very good high pressure". Man, I don't understand all no clue.

Tiny
Iancarvalho
Feb 16, 2013.

AD