Mechanics

WHY CAN'T I GET MY TO RUN?

1980 Mazda RX7 • 100,000 miles

I have rebuilt my 1980 rx7 carb, followed all the diagrams, cleaned and soaked all the parts, jets, etc. I am getting good fuel into the carb, the engine turns but won't start. I can hear that the car wants to start but it just won't fire. I have also replaced everything else, ie. Spark plugs, wires, distributor, thermostat, ect. I replaced the accelerator pump diaphragm and still nothing. What do you think? Oh, it did start once, the first time I reinstalled the carb, but since then nothing.

Avatar
Cwhill
May 18, 2012.



Is this what it was doing before carb rebuild?


Tiny
Fixitmr
May 18, 2012.
Sort of, when I bought the car it had a 1981, 82, or 83 carb on it, and the owner gave me the 1980 original carb that was on the car before he changed it. The car started with a great deal of effort but would not drive over 30 mph, I rebuilt the carb by soaking the parts and rebuilding it, then the car would go about 65 mph, but have no acceleration from 0 to 35. I then rebuilt the 1980 carb followed all the direction, pictures, manuals, vacuum diagrams, etc, etc. I started the car with no problem right after I re-installed the 1980 carb, then it died and won't restart. So to answer your question, yes it did this before. I am afraid there was some bad gas. I have also replaced all the in line fuel filters, spark plugs, wires, fluids, thermostat, 2 ignition control modules, and all the brakes.


Tiny
Cwhill
May 18, 2012.
Here are some images


Tiny
Cwhill
May 18, 2012.
Check that there is actually fuel in the carby, with air cleaner off check that fuel is spraying when you open throttle.


Mhpautos
May 19, 2012.