Wiring issue with windshield wipers( and washer pump ) and turn signals)

Tiny
MUTTMAN62
  • MEMBER
  • 2005 DODGE STRATUS
  • 2.7L
  • V6
  • FWD
  • AUTOMATIC
  • 58,504 MILES
My windshield wipers and washer pump as well as my turn signals only work on the ACC setting that is with the key turned backwards, engine not running, ( which does me no good ) they do however function perfectly in that accessory position, the Hazards work perfect in all key positions. Have gone as far as I can with it. Need your help Thank You Dave
Do you
have the same problem?
Yes
No
Thursday, July 2nd, 2015 AT 5:39 AM

5 Replies

Tiny
HMAC300
  • EXPERT
Have it scanned for a body module issue for wipers and check your front wiper relay under hood. If it works on acc I don't think It is the multi function switch. The same may be true for the t/s problem. Also check the ground behind the lh kick panel for corrosion as that is for the body module so that may be the cause as well.
Was this
answer
helpful?
Yes
No
Thursday, July 2nd, 2015 AT 6:52 AM
Tiny
MUTTMAN62
  • MEMBER
Thank you for your advice what is the lh kick panel please, the one under the inside fuse panel? This makes sense as the previous owner left windows open though out the rainy season last year
Was this
answer
helpful?
Yes
No
Thursday, July 2nd, 2015 AT 8:06 AM
Tiny
MUTTMAN62
  • MEMBER
Upon further checking I see the radio doesn't have power at the fuse either when key is on but does on ACC, that is right next to turn sig/wiper fuse (they are combined ) the ground seems to be ok, could it be a short in fuse panel? But if so why does it work on ACC when it won't work on ACC with bad fuse I'm just not getting it thanks
Was this
answer
helpful?
Yes
No
Thursday, July 2nd, 2015 AT 9:01 AM
Tiny
MUTTMAN62
  • MEMBER
Ok is there two different pwr supplies for the wipers turn signals and radio, and why would all three work just fine on ACC but none work when ignition is on or when engine running if you can solve this I will donate more $$ you have my word, I don't want to take it in anywhere, I don't trust shops and can't afford it I am baffled could it be ignition switch? ( Keyed one ) this car looks to good to be this screwed up

HELP
Was this
answer
helpful?
Yes
No
Thursday, July 2nd, 2015 AT 10:03 AM
Tiny
HMAC300
  • EXPERT
All of them go through the body module. Check the red/white wire at radio connection if it's got power there then that wold eliminate the ignition switch. Then check pink wire with key on and then on acc that comes from body module but if there is power problem there it would need to be scanned to see what the problem actually is. The body module would have to be installed by a pro anyhow as they have to be programmed to your vehicle.
Was this
answer
helpful?
Yes
No
Thursday, July 2nd, 2015 AT 12:03 PM

Please login or register to post a reply.

Recommended Guides