Transmission hard shifting

Tiny
EXISTEDTECH759
  • MEMBER
  • 1999 SATURN SL1
  • 1.9L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 121,000 MILES
I bought this car a little while ago and it had some shifting problems. The code it was throwing was that third gears ratio was off. After researching and having a mechanic look at it, we came up with it being a bad valve body. I changed the valve body and the wiring harness for the valve body which was cross threaded onto the valve body which I thought was the issue. The fix improved its shifting, but it only shifts good after it's been running for about 20 minutes, and it is at operating temperature. It still slams into reverse, and it has no fourth gear. I can't find anything else that could be wrong with it.
Do you
have the same problem?
Yes
No
Friday, March 18th, 2022 AT 11:32 PM

21 Replies

Tiny
EXISTEDTECH759
  • MEMBER
And update: I checked my fuse box which I should've done first. Rooky mistake I'll be honest. But I'm missing some fuses specifically a couple 30A fuses and a few other small fuses. I'm going to change them and check the other fuses and see what happens.
Was this
answer
helpful?
Yes
No
Friday, March 18th, 2022 AT 11:50 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Let me know if you are able to determine an electrical issue. However, it sounds like it could be related to a wiring harness issue or a line pressure issue. I recall from years ago, there was a technical service bulletin (TSB) related to hard or no shift. The harness to the transaxle was replaced as a fix.

If you are unable to determine if it is an electrical issue, let me know. Also, let me know the specific codes stored.

Take care,

Joe
Was this
answer
helpful?
Yes
No
Saturday, March 19th, 2022 AT 8:02 PM
Tiny
EXISTEDTECH759
  • MEMBER
So, no fuses were missing but I replaced the fuses that control the transmission line pressure. I'll look into the wiring harness.
Was this
answer
helpful?
Yes
No
Sunday, March 20th, 2022 AT 9:09 PM
Tiny
EXISTEDTECH759
  • MEMBER
Also, I'll get the codes scanned and I almost forgot that I replaced the wiring harness on the top of the transmission. So do I need to replace all the wiring or did you mean the one on top of the transmission?
Was this
answer
helpful?
Yes
No
Sunday, March 20th, 2022 AT 9:11 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
The one on top I believe is the one that was involved. However, if you get me the codes, I can try to focus on possible causes. I have a feeling it is a line pressure issue.

Is the ATF clean and full?

Let me know.

JOe
Was this
answer
helpful?
Yes
No
Monday, March 21st, 2022 AT 5:52 PM
Tiny
EXISTEDTECH759
  • MEMBER
I'll get the codes and I put fresh ATF and a filter on it less than 5,000 miles ago.
Was this
answer
helpful?
Yes
No
Tuesday, March 22nd, 2022 AT 6:00 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Sounds like a plan. Let me know what you find and any additional information you can provide.

Take care,

Joe
Was this
answer
helpful?
Yes
No
Tuesday, March 22nd, 2022 AT 7:47 PM
Tiny
EXISTEDTECH759
  • MEMBER
Okay. So, the codes are P0706 transmission range sensor A circuit range/performance, P0732 gear 2 incorrect ratio, P0733 gear 3 incorrect ratio, P0741 torque converter clutch circuit performance/ stuck off, P0781 1-2 shift.
Was this
answer
helpful?
Yes
No
Wednesday, March 23rd, 2022 AT 5:03 PM
Tiny
EXISTEDTECH759
  • MEMBER
I think I might have wired the harness incorrectly.
Was this
answer
helpful?
Yes
No
Wednesday, March 23rd, 2022 AT 5:04 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

I attached the wiring schematic for the transmission circuit. I had to cut the pic in half to make it readable for you, but I did overlap them so you can follow from one to the next.

Take a look through them and let me know if you notice any variations from what you have done. Also, let me know if the new wiring harness was a direct fit component.

Take care,

Joe

See pics below.
Was this
answer
helpful?
Yes
No
Wednesday, March 23rd, 2022 AT 6:57 PM
Tiny
EXISTEDTECH759
  • MEMBER
Well, I can't read diagrams well and three of the wires were the same color so I'm not sure what to do from here.
Was this
answer
helpful?
Yes
No
Wednesday, March 23rd, 2022 AT 7:02 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

I will break the schematic into three. See if that helps. Also, if the wiring colors match, confirm they are going to the correct places.

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Wednesday, March 23rd, 2022 AT 7:10 PM
Tiny
EXISTEDTECH759
  • MEMBER
Hey Joe,

I rewired the wiring harness and now the only code I have is third gear ratio incorrect and I still have no fourth gear. Where do I go from here?
Was this
answer
helpful?
Yes
No
Saturday, March 26th, 2022 AT 2:44 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Is the P0733 the only code left? I ask because this can be the result of the 4th gear solenoid. See the last pic below

The pics below are the diagnostics for the P0733. Let me know if there are any other codes set. P0734 is specific to a hydraulic condition with the 4th gear clutch so that one is important. However, there are several others listed in the pics below.

Take care,

Joe

See pics below.
Was this
answer
helpful?
Yes
No
Saturday, March 26th, 2022 AT 4:39 PM
Tiny
EXISTEDTECH759
  • MEMBER
I will check.
Was this
answer
helpful?
Yes
No
Saturday, March 26th, 2022 AT 4:42 PM
Tiny
EXISTEDTECH759
  • MEMBER
I apparently still have it wired wrong it's reading P0706, P0733, P0741, P0781, P0706, P0733, and P0741. And no, I didn't accidentally type three of those twice it had 7 codes and there were two codes for those three.
Was this
answer
helpful?
Yes
No
Saturday, March 26th, 2022 AT 7:55 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Okay,

The aforementioned diagnostics identify several codes that need to be addressed prior to focusing on a P0733. The only one you have that is present is the P0706, so let's see if we can get to the bottom of that code. It may be the cause of the 733 and the problems.

I attached the directions below which seem to focus specifically on the transmission range sensor. Take a look through them and let me know if you are comfortable performing the tests. I have a feeling this is where the problem is originating.

Let me know.

Joe

See pics below.
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2022 AT 1:47 PM
Tiny
EXISTEDTECH759
  • MEMBER
I will try to run that and get back to you.
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2022 AT 3:42 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Sounds good. Sorry for the different tests. You start into one, and it says to check something different if a specific code is set. Wiring can be a nightmare.

Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2022 AT 5:42 PM
Tiny
EXISTEDTECH759
  • MEMBER
I have a question about diagnostics. Do I need a special tool because we have a scanner, but I know there are tools that scan and run diagnostics and this one only scans.
Was this
answer
helpful?
Yes
No
Wednesday, March 30th, 2022 AT 9:34 PM

Please login or register to post a reply.

Sponsored links