TEMPERATURE GAUGE FLUCTUATIONS

  • Tiny
  • Hughdaleharris
  • TOYOTA PICKUP

I have a Toyota Pickup 1993 3.0L 4WD 270,000KM manual transmission.

I recently flushed the radiator because the coolant was looking a little brown. After I flushed the rad, the temperature gauge fluctuates all over the place, and unpredictably too. Before the flush, the temp gauge went to a certain temp and stuck there. Now, it'll rise when the engine is working harder but then fall all of a sudden, with the engine still working hard. Generally it's rising and falling unpredictably. I topped up the reservoir, and tried to expel all of the air. What is going on? Is there still air in the system? Did flushing it dislodge some sediment that is making the thermostat falter? Is it the water pump?

Do you
have the same problem?
Yes
No
Monday, June 11th, 2007 AT 12:31 PM

2 Replies

  • Tiny
  • Rasmataz
  • MEMBER

Cheap fix change the Stat, refill and bleed it.

Was this
answer
helpful?
Yes
No
Monday, June 11th, 2007 AT 5:40 PM
  • Tiny
  • Hughdaleharris
  • MEMBER

I went back and discovered that it was just the coolant that was low.

After I flushed the rad, I didn't wait long enough (i should have left it overnight) to let the engine cool then top up the coolant level. Because the engine was still a bit warm, the level looked good. Once it cooled completely, the coolant level went down and just needed topping up. I just needed to be more patient! Easy fix this time! :D

Was this
answer
helpful?
Yes
No
Tuesday, June 12th, 2007 AT 9:18 AM

Please login or register to post a reply.

Other Instrument Cluster Gauge Engine Temperature Stuck Questions