1999 Toyota Camry fan for cooling rad.

Tiny
LATINOAB
  • MEMBER
  • 1999 TOYOTA CAMRY
Engine Cooling problem
1999 Toyota Camry 4 cyl Front Wheel Drive Automatic 92.000 miles

I REPLACED ALL SENSOR'S ON THE RAD, THERMOSTAT, FAN RADIATOR SWITCH PLUS CHECKED ALL RELAY'S AND REPLACED FAN 1, 2, 3 RELAY'S. THERE IS POWER TO FAN, WHEN AC IS ON FAN WORK'S FINE. NEED HELP WHAT IS WRONG.
Do you
have the same problem?
Yes
No
Thursday, May 28th, 2009 AT 2:11 PM

22 Replies

Tiny
SERVICE WRITER
  • EXPERT
I need a clarification, is there on fan or two side by each?
Was this
answer
helpful?
Yes
No
Thursday, May 28th, 2009 AT 5:36 PM
Tiny
LATINOAB
  • MEMBER
Side by side both work if I pull the plug next to the battery and right lamp.
Was this
answer
helpful?
Yes
No
Thursday, May 28th, 2009 AT 6:24 PM
Tiny
LATINOAB
  • MEMBER
When the temp go's up fan will not go on must run with ac on.
Was this
answer
helpful?
Yes
No
-1
Thursday, May 28th, 2009 AT 6:35 PM
Tiny
SERVICE WRITER
  • EXPERT
IT sounds like it is operating normal. The primary fan will handle the heat and keep it in check, ( I assume you aren't overheating). The secondary fan comes on if the Primary fan can not adequetly prevent overheating temps of if the the A/C is on as the a/c is heavy on the system.
Was this
answer
helpful?
Yes
No
Thursday, May 28th, 2009 AT 6:58 PM
Tiny
LATINOAB
  • MEMBER
Yes the car is over heating got so hot my rad has a hole in the uper tank of my rad the plastic part
Was this
answer
helpful?
Yes
No
Thursday, May 28th, 2009 AT 9:08 PM
Tiny
LATINOAB
  • MEMBER
If my ac is off the rad fan will not run it will over heat
Was this
answer
helpful?
Yes
No
Thursday, May 28th, 2009 AT 9:10 PM
Tiny
SERVICE WRITER
  • EXPERT
I browsed past this, sorry.

What plug doe you mean?

IS it on this diagram?


http://www.2carpros.com/forum/automotive_pictures/30961_Untitlefan2_1.jpg



I'll email this diagram to you...too small to read.
Was this
answer
helpful?
Yes
No
Friday, May 29th, 2009 AT 5:32 AM
Tiny
LATINOAB
  • MEMBER
There is two gray plug's on the right side of the rad. The lower plug when you pull apart it will work the fan's. They will stay on when you turn the car on and off when car is off. But when I plug back up and car is hot cool down fan will not come on.
Was this
answer
helpful?
Yes
No
Friday, May 29th, 2009 AT 7:19 AM
Tiny
LATINOAB
  • MEMBER
Did you get my last mesg. Still need help problem not solved
Was this
answer
helpful?
Yes
No
Friday, May 29th, 2009 AT 6:16 PM
Tiny
SERVICE WRITER
  • EXPERT
Did you get my email?

Is this plug your referring to, on the diagram?
Was this
answer
helpful?
Yes
No
Friday, May 29th, 2009 AT 9:22 PM
Tiny
LATINOAB
  • MEMBER
DID NOT SEE IT ON DIAGRAM. BUT SOME ONE SIDE IT COULD BE THE FUSE IN MY ECU WHERE IS MY ECU LOCATED SO I CAN CHECK. THANKS
Was this
answer
helpful?
Yes
No
Saturday, May 30th, 2009 AT 10:52 AM
Tiny
SERVICE WRITER
  • EXPERT
Sorry, I assumed fuses were checked.

I doubt it is a fuse issue based on unplugging them changes the operation. The circuit that the plug is on is causing a problem is my thought.
Was this
answer
helpful?
Yes
No
Saturday, May 30th, 2009 AT 6:32 PM
Tiny
LATINOAB
  • MEMBER
The only fuse's that I did not check are the one on the ecu/ecm or can it be that plug when I check it with my tester it will read 0 when closed but 237 wiyh a beep when open.
Was this
answer
helpful?
Yes
No
Sunday, May 31st, 2009 AT 11:19 AM
Tiny
LATINOAB
  • MEMBER
What happened you stop helping me? My fan still is not working. Will not turn on when car is hot what to do. If the gray plug is in and if I pull the relay out a little the fan will come on but when the car is hot it will not turn off.
Was this
answer
helpful?
Yes
No
Saturday, June 6th, 2009 AT 10:46 PM
Tiny
SERVICE WRITER
  • EXPERT
I need to know what circuit that plug is on. What colors are the wires to the plug.
Post a picture as well.
I need to see the male and female views looking into the connector.
Was this
answer
helpful?
Yes
No
Sunday, June 7th, 2009 AT 7:51 AM
Tiny
LATINOAB
  • MEMBER
This is the plug to the rad sensor when I unplug the fan's both come on if I plug back in they work with ac not when car is hot. Did you get pc?
Was this
answer
helpful?
Yes
No
Sunday, June 7th, 2009 AT 1:16 PM
Tiny
LATINOAB
  • MEMBER
Could the temperature switch be Bad when car is hot it will not go up no higher then near half way but will not go half way and the car is all ready hot.
Was this
answer
helpful?
Yes
No
Monday, June 8th, 2009 AT 1:07 PM
Tiny
SERVICE WRITER
  • EXPERT
That was what I was thinking reading through.
This may help. The sensor may be giving false data and not turning on the fan.


http://www.2carpros.com/forum/automotive_pictures/30961_toy1_1.jpg



http://www.2carpros.com/forum/automotive_pictures/30961_toy2_1.jpg

Was this
answer
helpful?
Yes
No
Monday, June 8th, 2009 AT 6:51 PM
Tiny
LATINOAB
  • MEMBER
I ORDER SENSOR WILL BE IN WEDNESDAY WHEN I REPLACE IF IT WORKS I WILL DO A DONATION FOR ALL YOUR HLEP THANKS TONY.
Was this
answer
helpful?
Yes
No
Monday, June 8th, 2009 AT 7:56 PM
Tiny
LATINOAB
  • MEMBER
DID REPLACE TEMP SWITCH BUT FAN WILL NOT TURN ON AT HIGH TEMP. WHEN AC IS ON BOTH FANS WILL TURN ON AND OFF. WHAT TO DO
Was this
answer
helpful?
Yes
No
Wednesday, June 10th, 2009 AT 2:32 PM

Please login or register to post a reply.

Recommended Guides