1997 Toyota Camry sputtering

Tiny
APRILBREE
  • MEMBER
  • 1997 TOYOTA CAMRY
Engine problem
1997 Toyota Camry 4 cyl Wheel Drive Type unknown Automatic 160000 miles

when I start my car, it sputters, then turns, but sounds weak until I rev it. Then it seems fine. It doesn't stall at lights, and will start fine if I leave my car for several hours. Today, it sat all day, and when I tried to start it, it sputtered, started, then died immediately. Then it started again. I read a forum question on here that was similar to mine and someone replied to check the coolant guage. Recently, my thermostat was on hot, and someone helped me put coolant in my car. The car seemed fine after that. I know that the guage should read in the middle between hot and cold. But now mine sits under, about three quarter away from the cool. Is that something to consider? Someone suggested also that it could be the battery (but I don't think it sounds battery related).

Also. My car has a shake to it, so I took it in for a four-wheel balance and rotation. But the shake is still there, and now, it pulls to the left way more than I remember.(Sigh)

Thank you so much.I put in a donation under "aprilbree" but somehow I rerouted myself from that page to somewhere else. I blame that on being up til 1:30 when I should be sleeping :)
Do you
have the same problem?
Yes
No
Saturday, December 8th, 2007 AT 1:33 AM

1 Reply

Tiny
2CARPRO JACK
  • MECHANIC
  • 11,533 POSTS
If it is low on coolant, the sensor cant read the temp and doesnt know how to adjust the mixture. When was the last tune up? Try cleaning out the throttle bore around the butterfly with carb spray and a rag, that will help stabilize the idle
Was this
answer
helpful?
Yes
No
+2
Wednesday, December 12th, 2007 AT 4:23 PM

Please login or register to post a reply.

Sponsored links