22RE CUTS OUT WHEN UNDER LOAD AND WARM

1922 Toyota 4Runner

Tiny

oreeducator

January, 22, 2006 AT 5:36 PM

Hello Gents
I hope you all can help. I am stumped.
85 toyota 4 runner.
Brand new 22re motor with mild cam for torque.
Replaced fuel filter and pump in tank.
Runs great when cold but when warm cuts out realy bad under throttle load. Replaced TPS. Have vacums hocked up and timming at 5 degrees when bypass set. Any help would be greatly appreciated. Thanks

FOUND 25383 RELATED QUESTIONS

Cj Stalling When Idling

33 ANSWERS
44 IMAGES

Stalling Out

43 ANSWERS
48 IMAGES

5 Answers

Tiny

Hitek

January, 22, 2006 AT 8:20 PM

I think coolant temperature sensors or 02 sensors and or the mass air flow sensors.

Tiny

oreeducator

January, 26, 2006 AT 9:46 AM

Well still no luck. Rats!
Replaced o2 sensor and coolant temp. Mass Air flow checked out fantastic. Thought that I might have intake leak when warm but tried wd40 around entire intake and no change in idol. Any ideas? Thanks again.

Tiny

Hitek

January, 29, 2006 AT 1:28 AM

The CAT converter pluged?

Tiny

oreeducator

January, 30, 2006 AT 9:22 AM

Has no cat on it or sensor. 85 had only sensor at y pipe on exhaust.

Tiny

Hitek

January, 30, 2006 AT 9:45 PM

The last thing I can think about is the EGR valve systems?

Please login or register to post a reply.

Code Read Retrieval/Clear Scion XD
How to read codes Chevrolet Blazer
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear
Code Read Retrieval/Clear - Dodge Stratus
Read Codes Like a Pro