At idle or slow traffic my temperature gauge rises and my heater blows cool air

Tiny
MWIRE134
  • MEMBER
  • 2000 GMC JIMMY
  • 0.6L
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 250,000 MILES
Hi, I hope you know what causes this. When I am at idle or slow traffic my temperature gauge rises and my heat turns cool. So I put it in neutral and rev up the engine to around 3800 rpms for a little bit and the gauge goes back down and the heat comes back on. Everytime! I already changed the thermostat to an AC-Delco so I know its not that. I have checked the belt and the coolant level and they are fine. I thought I would change the radiator and while I was in there the water pump also. But I would hate to spend the time and money and find out it is something else. Is there anything else I can try or have you seen this problem before? Thank you. Sincerely Marty.
Do you
have the same problem?
Yes
No
Wednesday, December 28th, 2016 AT 2:06 PM

3 Replies

Tiny
JOHNNY G.JR
  • MEMBER
Sounds like system has air in it, needs to be bleed
Was this
answer
helpful?
Yes
No
+1
Thursday, December 29th, 2016 AT 1:30 AM
Tiny
MWIRE134
  • MEMBER
Thanks JONNY G. JR. It most certainly was air in the system. Bled it through a bleed plug just below the thermostat housing and everything is working fine now. Thanks for saving me a lot of time and money. Sincerely, MWIRE134
Was this
answer
helpful?
Yes
No
Thursday, December 29th, 2016 AT 2:23 PM
Tiny
KEN
  • ADMIN
Glad you could get it fixed please use 2CarPros. Com anytime we are here to help

Best, Ken
Was this
answer
helpful?
Yes
No
Tuesday, January 3rd, 2017 AT 1:30 PM

Please login or register to post a reply.

Recommended Guides