Service light will not turn on/blink with all the other instruments when vehicle is on

Tiny
DARY CARY
  • MEMBER
  • 1996 DODGE CARAVAN
  • 196,000 MILES
Hello, the "service engine soon" light does not flash on with the other lights car on, pre start. The bulbs are fine and I replaced the part. It is still not flickering. I cannot pass smog with that issue. Does anybody have an answer?
Do you
have the same problem?
Yes
No
Saturday, May 18th, 2019 AT 4:50 PM

2 Replies

Tiny
SCWICKEDSTANG
  • EXPERT
Hello,

Can you please provide us with the engine size and transmission for your vehicle. It will make a difference when we are looking up the information for you. We are asking this because we want to provide you with the correct information to fix this issue. We have guides available, once we receive your vehicle's information.

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
Sunday, May 19th, 2019 AT 2:46 AM
Tiny
SCWICKEDSTANG
  • EXPERT
Hello again,

So after doing more research it turns out that the information for an inoperative Malfunction Indicator Lamp (MIL) or in your vehicle's case "service engine soon" lamp inoperative is the same no matter what engine/transmission combination you have, so I have included the troubleshooting guide in the diagrams down below. Please go through the guide and get back to us with what you are able to find out.

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
Sunday, May 19th, 2019 AT 3:12 AM

Please login or register to post a reply.

Recommended Guides