2005 Scion TC Hesitats at idle and when I decelerate

Tiny
BTPORTER213
  • MEMBER
  • 2005 SCION TC
  • 4 CYL
  • FWD
  • MANUAL
  • 59,000 MILES
My car kinda chugs at idle and when it is decelerating. My check engine light is on and it says failure in my front oxygen sensor. Would my oxygen sensor cause this. I also want to note that I am getting terrible gas mileage now also? Any info would help thank you much bj porter
Do you
have the same problem?
Yes
No
Thursday, December 4th, 2008 AT 6:14 AM

5 Replies

Tiny
KHLOW2008
  • EXPERT
Hi bj porter,

Thank you for the donation.

Yes, a failed O2 sensor can cause bad idling and very poor mileage.

However I would suggest checking the spark plugs as well.

I would like to know the exact error code that you got for the the O2 sensor. Sometimes the O2 sensor shows a code because of other influences, eg, running lean or rich
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 6:53 AM
Tiny
BTPORTER213
  • MEMBER
I cant remember the exact code but it did say it was running lean
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 7:50 AM
Tiny
KHLOW2008
  • EXPERT
Hi bj porter,

When engine is running lean, possible causes are
1. Faulty O2 sensor.
2. Leaking vacumn
3. Clogged fuel filter
4. Faulty fuel pressure regulator, weak fuel pump.
5. Throttle position sensor out of calibration.
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 8:41 AM
Tiny
BTPORTER213
  • MEMBER
Whats your take on these universal O2 sensors or should I just pony up and get the $185 bosch brand thank you so much for your help
Was this
answer
helpful?
Yes
No
Thursday, December 4th, 2008 AT 8:53 AM
Tiny
KHLOW2008
  • EXPERT
Hi bj porter,

So far I have not known of any complications for Scions using universal O2 sensors, so I guess it should be ok to use it.
Was this
answer
helpful?
Yes
No
Friday, December 5th, 2008 AT 7:30 AM

Please login or register to post a reply.

Sponsored links