Windshield wipers are not working right

Tiny
NJBLOODLINE
  • MEMBER
  • 1999 SATURN SL2
Four cylinder front wheel drive automatic 132,000 miles

the wipers on my car only work on the highest setting and turn on and off randomly. Also, the windshield wiper fluid sprays at my windshield until it is empty and even when it is empty it always tries to spray more.
Do you
have the same problem?
Yes
No
Wednesday, April 28th, 2010 AT 10:22 AM

2 Replies

Tiny
SATURNTECH9
  • EXPERT


http://www.2carpros.com/forum/automotive_pictures/416332_1999_sl2_wiper_connector_to_switch_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_1999_sl2_wipers_run_on_high_only_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_1999_sl2_wiper_switch_tests_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_1999_sl2_wiper_wire_diagram_1.jpg


here is the trouble tree for wipers only work on high. i also gave you a wire diagram so you can trace and see why your washer motor runs all the time you will need a volt ohm meter so you can do some testing.let me know what you find and if you have anymore questions.
Was this
answer
helpful?
Yes
No
Thursday, April 29th, 2010 AT 1:20 PM
Tiny
MACIALEXANDRA
  • MEMBER
  • 1993 SATURN SL2
Two wheel drive automatic 226,000 miles

Windshield wipers started slowly going up and stop 3/4 of the way, and now they do not work. When I hit the switch to make them go they twitch really quick, but do not do anything. Like they want to move, but they do not.
We put a new motor in and fuse and they still are not working. Is is the linkage? It has has been such a pain!
The wiper fluid still works though, so please help!
Was this
answer
helpful?
Yes
No
+1
Friday, January 13th, 2017 AT 4:06 PM (Merged)

Please login or register to post a reply.

Recommended Guides