1994 Saturn SL2

Tiny
MILESBUGG
  • MEMBER
  • 1994 SATURN SL2
1994 Saturn SL2 4 cyl

i have a saturn sl2 that wont start. Have spark injectors not pulsing. Hooked a test light to the harness and it light up with the key off when key on the test light goes out all the fuses are good think I have an open circuit just can't seem to find it
Do you
have the same problem?
Yes
No
Tuesday, July 6th, 2010 AT 7:25 PM

9 Replies

Tiny
SATURNTECH9
  • EXPERT
To check to see if the injectors are getting a good signal from the pcm you unplug each injector and plug a noid light in each injector connector crank the engine and if the light flashes then you know you are getting a good signal.
Was this
answer
helpful?
Yes
No
Wednesday, July 7th, 2010 AT 12:52 AM
Tiny
MILESBUGG
  • MEMBER
Meant to say that I had already checck the plug with a noid light and it didn't flash at all
Was this
answer
helpful?
Yes
No
Wednesday, July 7th, 2010 AT 9:10 PM
Tiny
SATURNTECH9
  • EXPERT
Let's do this put the key in the run position and check to see if you have power on both side's of the injector fuse in the under hood fuse box. If you do then go to each injector harness and see if you have power at the pink and black wire's. Let me know what you find.
Was this
answer
helpful?
Yes
No
Thursday, July 8th, 2010 AT 12:37 PM
Tiny
MILESBUGG
  • MEMBER
I did that all ready. With the key in the off position I put a test light on that fuse and it lite up but if I turn it to the on position it will not light up
Was this
answer
helpful?
Yes
No
Thursday, July 8th, 2010 AT 4:44 PM
Tiny
SATURNTECH9
  • EXPERT
Ok that's working backwards the INJ fuse should have power when the key is in the on position not when it is off position. Lets do this go to the wire's going into your ignition switch you should have a constant power to the red and white wire with the key off. Now with the key off test for power at the pink wire it shouldn't have any power. Now test the pink wire for power again with the key in the run position it should have power now. Let me know what you find.
Was this
answer
helpful?
Yes
No
Thursday, July 8th, 2010 AT 5:15 PM
Tiny
MILESBUGG
  • MEMBER
Did what u said and it worked the way u said. Hooked the noid light up back to the harness and still no flash I even put a used pcm and still it wont crank right now im lost
when I replace the engine in it I never add any coolant just wanted to hear it start up first. Will it start without coolant in it
Was this
answer
helpful?
Yes
No
Sunday, July 11th, 2010 AT 4:56 PM
Tiny
SATURNTECH9
  • EXPERT
If your getting power to the INJ fuse with the key turned off and no power with the key turned on and the ignition switch is working the way it should then I would be looking at the under hood fuse box. Something is not right there. Also you can start it without coolant but if it started I would turn it right back off you don't want it to run without coolant.
Was this
answer
helpful?
Yes
No
Monday, July 12th, 2010 AT 2:02 AM
Tiny
MILESBUGG
  • MEMBER
I think im getting power to the inj too I was using a test light I connected the lead off the test ight to the neg side of the battery and probed the inj harness and when I turn the key in the on postion it lights up just not pulsing
Was this
answer
helpful?
Yes
No
Monday, July 12th, 2010 AT 5:40 PM
Tiny
SATURNTECH9
  • EXPERT
Try this hook the test light to the positive side of the battery and touch the test light to the dark blue and then the dark green wire's at the injector connector's while you have someone crank it over each time you move to the next wire. Does any of wire's you touch make the test light flash while cranking?
Was this
answer
helpful?
Yes
No
Monday, July 12th, 2010 AT 5:57 PM

Please login or register to post a reply.

Recommended Guides