1998 Saturn SL1 Intermittant errratic running engine then s

Tiny
TURBO1960
  • MEMBER
  • 1998 SATURN SL1
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 145,000 MILES
I have replaced ignition wires, both coil packs, ignition module, crankshaft sensor, and fuel pump (the motor inside pump, not entire module)
all within the last 20,000 miles. Engine runs fine for while, then RPM swings erratically and stalls. I disconnect the battery, then reconnect it and it starts then runs erratically and stalls. Then I let car sit for a few days, reconnect battery and it runs fine. For awhile. After a period of time. It'll begin running erratically again. There re NO codes at emission inspection station.
Something tells me I need to buy an entire new fuel pump assembly made by Saturn. Thoughts?
Do you
have the same problem?
Yes
No
Monday, October 27th, 2008 AT 6:32 PM

1 Reply

Tiny
TURBO1960
  • MEMBER
I discovered the solution to my erratic running 1998 Saturn engine. Replacement of the Engine Temperature Coolant Sensor repaired the problem. The Coolant sensor directly regulates Saturn's fuel injection system. There was a small crack in the ceramic "pick-up" area of the sensor which created an open circuit over extended running times. I placed the sensor in hot water on a stove to re-create the engine operating temperature and measured the resistance with ohm meter. As temperature increases. Ohms decrease. After extended heat. The circuit opened (an open circuit should never happen) thereby stopping the flow of heat informtion to the the PCM, (car computer) which caused the fuel injection to go haywire and shutdown. Disconnecting the battery reset the electronics. But the faulty sensor repeated its failing performance at normal operating temperature, which is why the car wouldn't start immediatley, but cranked up the next morning when cold. You can use this same testing procedure to check the ohm resistance of the Crankshaft Position Sensor (heat can cause an open circuit on aging sensors). Lessons learned: replace all your engine sensors at 100,000 miles.
Was this
answer
helpful?
Yes
No
Friday, October 31st, 2008 AT 10:17 AM

Please login or register to post a reply.

Recommended Guides