1996 Saturn SL1

Tiny
GRGRAMMA55
  • MEMBER
  • 1996 SATURN SL1
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 200,000 MILES
Car idles poorly at stop lights what's wrong?
Do you
have the same problem?
Yes
No
Friday, November 6th, 2009 AT 1:21 PM

8 Replies

Tiny
PITYPET
  • MEMBER
My 97 does the same thing. It never stalls but when I stop at a light it sounds like it wants to. If I put it in neutral it stops. I've taken it to three different places and none could fix it or even tell me what it was. I've been going through this for 2 years. I hope you have better luck.
Was this
answer
helpful?
Yes
No
Tuesday, November 24th, 2009 AT 7:53 PM
Tiny
KEVIN12881
  • MEMBER
Alright, I have seen a few of these and what you need to understand is that when you ae at a stop in a car with an automatic transmission, the engine is under load when in gear at a stop, meaning the engine is working hard. Several things can result in this. The fisrt few show up at stopping and are: fuel pump, sensor and filter. These things first start to show at a stop b/c the engine is under load and not getting any more fuel than at regulor idle. If you do not have an overall power problem start there. If the problem is from an overall loss of power than you need to make sure you keep up with you routine maintenance. Like air filter, plugs, plug wires, coils and what not. If those are not it then there is many more areas to look at like everything from your distibuter cap to your EGR valve. Do you have an overall loss of power. Start by going to any auto part store for a FREE computer scan to see if any codes pop up
Was this
answer
helpful?
Yes
No
Tuesday, November 24th, 2009 AT 8:50 PM
Tiny
PITYPET
  • MEMBER
Thanks but I have a standard transmission.
Was this
answer
helpful?
Yes
No
Wednesday, November 25th, 2009 AT 1:05 AM
Tiny
SATURNTECH9
  • EXPERT
Are u sure u have a rough idle and not just a excessive vibration at idle saturns get whats called a collasped upper motor mount causing a bad vibration that can be mistaken I have had alot of customers come in and say they have a rough idle and it was just a bad mount. Iam just try to make sure were not chasing our tails here thinking it a rough idle when its a simple fix like a mount. So does the engine rock back and fourth at idle can u see the rpms bouncing around on the tach or does it just vibrate alot at idle?
Louie
Was this
answer
helpful?
Yes
No
Wednesday, November 25th, 2009 AT 11:15 AM
Tiny
PITYPET
  • MEMBER
Nothing happens with my rpms. I think some other people had that problem. I will make sure the next time I drive and also will ask someone to check the motor mount I don't know what that is but I don't think it applies here.
Was this
answer
helpful?
Yes
No
Wednesday, November 25th, 2009 AT 3:59 PM
Tiny
GRGRAMMA55
  • MEMBER
Understand load on engiine. Have replaced MAP sensor, Oxygen sensor, plugs wires, one coiil, fuel filter IAC. Motor mounts are fine. Going to clean EGR in a day or two when have time. Can you make any other suggestions. No check engine lights have appeared since doing these replacements.
Was this
answer
helpful?
Yes
No
Thursday, November 26th, 2009 AT 1:56 AM
Tiny
SATURNTECH9
  • EXPERT
Let's back up here sounds like we have replaced alot stuff let's start by why u replaced each item? I can suggest things for u to replace but that's not a good way to fix something like ur egr if it were sticking it would set a code u said u don't have any codes. Also what are the symptoms I was asking u that in my post to u can u see the rpms on the tach move at idle does the enging rock at idle or does it just vibrate at idle?Also how did u check ur mounts does it miss in gear out gear or both in gear and out of gear at idle?How does it run when ur driving down the road smooth plenty of power lack of power does it miss while driving down the road?Have u checked for a vaccuum leak?I would start by checking ur pcv hose the s shaped hose from ur cam cover to ur intake the they become soft and colaspe and cause all kinds of problems they even get a hole in them causing rough idles high idles. Have u checked to make sure ur battery cables are clean and tight that could cause strange idles. Have u looked at the spark plugs yet another source of strange idles. Let me know the answers and what u find.
Louie
Was this
answer
helpful?
Yes
No
Thursday, November 26th, 2009 AT 9:42 AM
Tiny
GRGRAMMA55
  • MEMBER
My main problem is very bad idle at stop lights once the rpms go all the way down. Runs fine at higher speeds. Good power. Replaced pvc and hose before starting having trouble. #3 plug fouls out often. Everytime I replace plugs which is about every 4 months. Power comes back. All parts were replaced trying to fix problem with idle. All of them were either burnt or clogged with carbon
Was this
answer
helpful?
Yes
No
Thursday, November 26th, 2009 AT 1:35 PM

Please login or register to post a reply.

Recommended Guides