1992 Saturn SC2 CAR CUTS OUT AFTER WARMING UP

Tiny
SCTWINCAM
  • MEMBER
  • 1992 SATURN SC2
  • 4 CYL
  • FWD
  • MANUAL
  • 105,000 MILES
Ok so I have a 92 saturn that runs fine for about 10 minutes each morning after that I cant hardly drive it. When im driving it cuts out realy bad and then it will staitin out and 30 seconds later same thing.I have already tried the coolant temp sensor coil packs plugs wires crank position sensor. And I dont have a check engine light and it does work cause I can unplug a sensor and it comes on. Any ideas would be great.
Do you
have the same problem?
Yes
No
Monday, July 12th, 2010 AT 5:22 PM

8 Replies

Tiny
SATURNTECH9
  • EXPERT
Which coolant temp sensor did you change the top one with one wire or the bottom one with two wire's?Also what sensor did you unplug that keep's the service engine soon light on?
Was this
answer
helpful?
Yes
No
Monday, July 12th, 2010 AT 5:26 PM
Tiny
SCTWINCAM
  • MEMBER
I replaced the one with two wires goin to it. The sensor I unpluged was thi iat sensor
Was this
answer
helpful?
Yes
No
Monday, July 12th, 2010 AT 5:37 PM
Tiny
SATURNTECH9
  • EXPERT
I would inspect the connector going to the coolant temp sensor you replaced for being corroded. Also why did you unplug the iat sensor?I emailed you the procedure for getting your trouble code's please let me know which code's you have.
Was this
answer
helpful?
Yes
No
Monday, July 12th, 2010 AT 5:49 PM
Tiny
SCTWINCAM
  • MEMBER
The only reason I unpluged my iat sensor is to see if my ses light would come and see if it worked. The conector was the first thing I tried.
Was this
answer
helpful?
Yes
No
Monday, July 12th, 2010 AT 5:54 PM
Tiny
SCTWINCAM
  • MEMBER
Just got done with the test and didnt have any codes exept the iat sensor but I disconected the battery and hooked it back up and it wnet away.
Was this
answer
helpful?
Yes
No
Monday, July 12th, 2010 AT 6:04 PM
Tiny
SATURNTECH9
  • EXPERT
You said you replaced both coil's but did you replace the module underneath the coil's?Also when it stalls when warm does it start right back up?Have you checked the fuel filter to see if it's restricted?The fuel filter on those car's get changed every 30,000 mile's and by then they get pretty restricted. Also when it warms up and run's bad you should test the fuel pressure they rent the gauge's at auto zone. If all that check's good I would also test for excessive back pressure when it warms up and runs bad.
Was this
answer
helpful?
Yes
No
Tuesday, July 13th, 2010 AT 11:48 AM
Tiny
SCTWINCAM
  • MEMBER
Yea I replaced the module and I just put a new fuel filter on bout 1500 miles ago. It never realy stals it just idles down to bout 300 then back to1500 then it idles normal, and I replaced the tps.I know its geting to much fuel because I followed it in my other car and it has a lot of black smoke and smells realy rich. The only thing I havent done yet is check the fuel preasure.
Was this
answer
helpful?
Yes
No
Tuesday, July 13th, 2010 AT 1:59 PM
Tiny
SATURNTECH9
  • EXPERT
The idle that raise's up and down could be a dirty idle air control valve or sticky carboned up valves. With the car in park run the rpms up to 2500 rpms with the engine warmed up for 30 seconds then release the gas quickly and let it drop back down to idle. Do this 3 time's does it surge up and down to try to idle the correct rpm to idle or die?I would also check the fuel pressure when it start's running poorly also have you checked the exhaust back pressure when it act's up and the car is running so bad?
Was this
answer
helpful?
Yes
No
Wednesday, July 14th, 2010 AT 12:36 PM

Please login or register to post a reply.

Recommended Guides