1999 SAAB 9-5 wants to shut off at idle

Tiny
LISAJOSE
  • MEMBER
  • 1999 SAAB 9-5
  • 4 CYL
  • AWD
  • MANUAL
  • 10,900 MILES
My check engine light was on so I took it to auto zone they hooked it up to a machine and said my oxygen sensor was bad so he reset the light now it wants to shut off at stop signs and red lights unless I put it in neutreal ang go on the brake and gas at the same time help
Do you
have the same problem?
Yes
No
Wednesday, February 4th, 2009 AT 4:38 PM

5 Replies

Tiny
FACTORYJACK
  • EXPERT
When you cycle key to on position, do you hear clicking under the hood near the throttle body(approx 6 times)? If so, the throttle assembly is in limp home mode and will need reset. This typically is not a result of clearing the codes, more likely a result of throttle faults that would set codes as well. Did they give you the code #'s that were set?
Was this
answer
helpful?
Yes
No
Wednesday, February 4th, 2009 AT 10:03 PM
Tiny
LISAJOSE
  • MEMBER
I dont recall any noise and no yhey did not give me a code but some times I try to start the car and it wont until I take the key out and flip it around.
Was this
answer
helpful?
Yes
No
Friday, February 6th, 2009 AT 5:53 PM
Tiny
FACTORYJACK
  • EXPERT
Flipping the key should have nothing to do with it. As far as recalling a noise, I need you to check for it currently, it could save a lot of time. Lift the hood, have someone stand over the front of the engine compartment, and turn the key on. If it is in limp home, there will be a click-click, click-click, click-click, click-click, click-click, click-click. 6 double clicks. Try starting it with a little pressure on the gas pedal, see if that makes a change. Either you have it in limp home, or there is an air leak in the induction plumbing after the mass airflow sensor. I would recommend a saab dealer, or credible independant shop that is capable of working on it.
Was this
answer
helpful?
Yes
No
Friday, February 6th, 2009 AT 10:27 PM
Tiny
LISAJOSE
  • MEMBER
I had some one at the hood no noise. I drove the car today and at first it was ok then it seems like the idling drops and then shuts off at least 4 tims at one traffic light it seems to start right up though. Is there an idling srew that I could turn up. Tring to have someone to help me I lost my job and $ is tight so I am very greatful for all your help thank you
Was this
answer
helpful?
Yes
No
Sunday, February 8th, 2009 AT 3:08 PM
Tiny
FACTORYJACK
  • EXPERT
There is no adjustment, it is electronic. It sounds like you have an inlet air leak. Check the hose connection at the throttle body, grab and pull up, it shoud be secure. Check all of the plumbing where there are clamps.
Was this
answer
helpful?
Yes
No
Monday, February 9th, 2009 AT 9:57 PM

Please login or register to post a reply.

Recommended Guides