Radio and key fob stopped working

Tiny
DAN0399
  • MEMBER
  • 2007 CHRYSLER TOWN AND COUNTRY
  • 3.8L
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 197,000 MILES
Radio and key fob stopped working simultaneously. When I key on the cluster will go through a self calibration mode. On one occasion when the temperature was 28 degees outside everything worked for that one day. The next day and since it has been in the 40 degree range and I am back to no radio and key fob operation. I looked at a schematic and noticed both the radio and key fob are connected to the body control module. I was told there is another module near the battery that could also be bad but don't know. What the name of it is. Got any ideas on what I should replace? All fuses were checked and are good.
Thanks,
Dan.
Do you
have the same problem?
Yes
No
Thursday, December 10th, 2015 AT 2:57 AM

8 Replies

Tiny
HMAC300
  • EXPERT
The other module is called a TPIM or integrated power module under the fuse box under hood. Before you do anything have a pro scan for codes to see if any are bad or screwed up. Have you checked fuses under hood as well as in car? Auto parts can check your key fob to see if that works.
Was this
answer
helpful?
Yes
No
Thursday, December 10th, 2015 AT 9:45 AM
Tiny
DAN0399
  • MEMBER
I did not check the fuses under the hood, but since everything started working again for one day when the temps were below 32 degrees, I assumed all fuses were good. I did a check for fault codes by turning the ignition on and off 3 times. The only code was a P0404 which I think was for a faulty EGR valve. Is the pro scan something Auto Zone Does for free?
I will check the fuses today just to be sure.
Thanks.
Was this
answer
helpful?
Yes
No
Friday, December 11th, 2015 AT 9:34 AM
Tiny
HMAC300
  • EXPERT
Auto parts can only check engine/trans codes and nothing like any other module a garage has to do that.
Was this
answer
helpful?
Yes
No
Friday, December 11th, 2015 AT 10:02 AM
Tiny
DAN0399
  • MEMBER
I removed the TPIM which was mounted on the front side of the power distribution center. I put it in the freezer for roughly 36 hours then reinstalled it when it was ice cold. Still no luck, the radio and key fob still do not work. I might have to bring it to the dealer or a garage to have a pro scan done. I looked at some schematics and both the radio and keyless entry are wired into the body control module located up under the dash above the brake pedal. Wonder if that could be it. Thanks for your help.
Was this
answer
helpful?
Yes
No
Saturday, December 19th, 2015 AT 10:56 AM
Tiny
HMAC300
  • EXPERT
Ti body module cold be it but only a pro can scan the tpim and body modules
Was this
answer
helpful?
Yes
No
Saturday, December 19th, 2015 AT 12:14 PM
Tiny
DAN0399
  • MEMBER
I got a hold of a diagnostic scanner from work. We supply the abs module for that van. Here are the codes I found.
Body controller:
0E - MSM msgs not received
10-FCM msgs not received

Front body control module: I think this one is the TPIM
ACTIVE Fults
16- Comm Loss With Radio

Historic Faults
16 - Comm loss with Radio
04 - loss comm with BCM
06 - Ign Run Start wiring
18 - Comm loss with EATX
1E - Washer output shorted to Batt.
Module number read is is the part number on the TPIM 05144579AC!
Was this
answer
helpful?
Yes
No
Thursday, January 7th, 2016 AT 7:07 PM
Tiny
HMAC300
  • EXPERT
All these are going to have to be checked by a pro you have a communication problem so its' either wiring or a can problem.
Was this
answer
helpful?
Yes
No
Friday, January 8th, 2016 AT 6:43 AM
Tiny
DAN0399
  • MEMBER
Ok I'll keep you posted.
Was this
answer
helpful?
Yes
No
Friday, January 8th, 2016 AT 2:29 PM

Please login or register to post a reply.

Recommended Guides