1998 Plymouth Voyager Voyager stall when put into drive or


Engine Mechanical problem
1998 Plymouth Voyager 6 cyl Two Wheel Drive Automatic 90000 miles

This problem occured before the tune up. I was hoping the tune up would fix the problem. There is no Engine service light on, still got the codes from the computer which showed no problems.
The engine will idle fine but as soon as you put it into gear it begins to stall. I can however stomp on the gas to keep it running, but I don't think that is the safest solution.

Any help would be great.

Do you
have the same problem?
Thursday, April 16th, 2009 AT 8:37 AM

1 Reply


Was the battery disconnected or died recently? If it was, minimum throttle must be relearned by the engine computer. Until this is done, the computer doesn't know when you have your foot on the gas pedal and when it must be in control of idle speed.

It knows your foot is off the pedal when you're coasting. The strategy it uses is higher than normal manifold vacuum for seven seconds. High vacuum will occur if you snap the throttle open and closed real fast, but not for seven seconds. You have to coast down from highway speed for the high vacuum to occur for seven seconds or longer.

When these conditions are met, the engine computer looks at the voltage from the throttle position sensor and puts that in memory. The next time it sees that same value, it knows it has to control idle speed.

Most technicians will perform a test drive specifically to prevent this customer complaint after doing any work that requires disconnecting the battery.

Drive on the highway, then coast for seven seconds without touching the brake or gas pedals.

There should also be an idle "flare-up" when you start the engine. If it doesn't run up to about 1500 rpm when you start it, there could be a problem with the idle speed motor or its air passage could be plugged with carbon.


Was this
Saturday, April 18th, 2009 AT 3:59 AM

Please login or register to post a reply.

Recommended Guides