Code P0014, no throttle response

Tiny
JOEBOSS IMEOBONG SAMPSON
  • MEMBER
  • 2010 TOYOTA COROLLA
  • 1.8L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 163,000 MILES
Car drives fine but after a while on braking cuts off the throttle body so the car only idles and rolls in drive. I have replaced the ECM as advised but the problem persist. Funny thing is when car cold and reset of ECM by removing battery head for about 10 minutes, the car drives again normally until it pops again in no long time.
I have a pending P0014 on the car and that gas even there since.
I am confused and don't know what else to do. Driving the car with fear of being stuck on the highway.
Do you
have the same problem?
Yes
No
Sunday, March 21st, 2021 AT 9:14 AM

1 Reply

Tiny
KASEKENNY1
  • EXPERT
Unfortunately the ECM is seeing the cam out of time. This does not mean that the engine is actually out of time but it is not changing the timing of this camshaft when it is supposed to. So it is telling it to be in one place and it thinks it is not there. This system is called a variable valve timing system.

Here is a guide that will help with this:

https://www.2carpros.com/articles/how-camshaft-variable-valve-timing-works

Below you will find the testing that we need to run through in order to figure out what is needed. More than likely it is a cam sensor but it could be other things so it is a good idea to run through it.

Let me know what questions you have. Thanks
Was this
answer
helpful?
Yes
No
Monday, March 22nd, 2021 AT 4:51 PM

Please login or register to post a reply.

Sponsored links