ENGINE RUNS ROUGH AFTER WARM UP

2000 Nissan Xterra

Tiny

clascola

October, 17, 2009 AT 5:26 AM

Engine Performance problem
2000 Nissan Xterra 6 cyl Two Wheel Drive Automatic

My xterra runs terrible (cant make it up hills) after warm up. At first I thought it was a clogged fuel filter because it was behaving like it was starved for fuel. I replaced the feul filter then the cap, plugs, and plug-wires. Still runs really rough after warm upl

FOUND 4561 RELATED QUESTIONS

Running Rough

27 ANSWERS
34 IMAGES

Idles Rough/changed Ects

37 ANSWERS
3 IMAGES

1 Answer

Tiny

jbstevens8

October, 21, 2009 AT 9:56 AM

I had a similar problem. Truck would misfire and rough idle after engine was warm. Same knock sensor code.

I had a distributor bearing that failed in the distributor rotor. When engine was cool, the rotor was moving in all the thick grease so no problem. Once engine warmed up, the grease thinned out and truck was surging, cutting off, rough idle, extreme heat in exhaust.

Mechanic said the rotor looked like a rats nest of metal shavings from the failed bearings and washer.

Replaced distributor cap, distributor rotor, spark plugs, and wired. ($1100 total) Now I need to replace the valve cover gaskets since the intense heat melted the gasket and is causing a minor oil leak.

Heat was caused from the misfiring, which opened the injectors, causing them to dump huge loads of fuel into the cylinder. All that gas caused the temperature to skyrocket. Fortunately, I did not ruin the Cat converters with the heat.

Please login or register to post a reply.

Code Read Retrieval/Clear Mercedes Benz
Code Read Retrieval/Clear Scion XD
How to gather codes Ford Explorer
Code Read Retrieval/Clear - Dodge Stratus
Read Codes Like a Pro
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear Mercedes-Benz C230