ROUGH IDLE?

Nissan Altima

Tiny

Mjochana

February, 13, 2007 AT 10:03 PM

I am not sure what the problem is. I bought a used Altima GLE. I had trhe engine mounts replaced, the valve cover gasket changed and new plugs, wires, cap/rotor and air filter.

It seems that the car has a vibration when it is idleing, the mechanic that did the work has told me, it could be bad gas so I should use a fuel injector additive and it should get better over the next few months.

There are codes that came up,
1. P0440 Evaporative emission control system small leak, negative pressure
2. P1448 Vent control valve.

The mechanic says these have nothing to do with the vibration/idle issue.

Is it possible the work he did may have caused this?

FOUND 2422 RELATED QUESTIONS

3 Answers

Tiny

rasmataz

February, 14, 2007 AT 5:46 AM

Rough Idle-did he check the Evap system thoroughly?

Tiny

Mjochana

February, 14, 2007 AT 10:05 AM

No he didn't, just hooked up the monitor under the dash by the fuse box and recived the codes.

I have another question,

Now. When I run the car for a while with the A/C, there is white smoke coming fromt he engine compartment, towards the back. So it does not look like it is coming from the radiator. What wonderful problem might this be?

Tiny

Mjochana

February, 14, 2007 AT 10:07 AM

Sorry

it is a 1998 Nissan Altima GLE 91,000 mile

Please login or register to post a reply.

Cylinder Head Valve Job Guide
Vacuum Leak Test and Repair - All Cars
Fuel Injector Replacement Ford 5.4L V8
Spark Plug Replacement Honda Element