2009 Mitsubishi Lancer Engine Misfire when headlights are t

Tiny
HOUDINI
  • MEMBER
  • 2009 MITSUBISHI LANCER
Engine Performance problem
2009 Mitsubishi Lancer Front Wheel Drive Automatic 30000 km

My Lancer GTS has no problem whatsoever when I don't turn on my headlights. (Stock headlamps) It is adequately powered and smooth. My problem surfaces whenever I turn on my headlights. At speed around 140km/h, my engine will start to jerk/pullback or misfire whatever you call it without fail. It is worse when it is going uphill. I've tried switching off the air-cond but it makes no difference. The minute I switch off the lights, the car immediately restored its competency and run normal! The problem is not very negligible at speed below 100 km/h with headlights on.

I've sent my car to Mitsubishi and they replaced a new ECU for my car. I just got back my car and it makes no difference. I face the same problem whenever I switch on my headlights. FYI, I've tested my altenator and battery. They're working fine. I'm at wits end. I know it has to be a wiring problem but I need to narrow down the usual suspects.
Do you
have the same problem?
Yes
No
Tuesday, March 16th, 2010 AT 9:15 AM

2 Replies

Tiny
DOCFIXIT
  • MEMBER
Hi
Check ground connection behind left headlight attached to frame. See if it is tight and clean
Let me know
Thanks for donate
Was this
answer
helpful?
Yes
No
Tuesday, March 16th, 2010 AT 1:01 PM
Tiny
KHLOW2008
  • EXPERT
Hi houdini,

Thank you for the donation.

As the vehicle is new, and the ECU, which also controls the charging system has been replaced, I believe it should not be a fault with any components.

I agree that it should be an electrical fault and the most likely cause would be bad ground circuits. Recheck the ground circuits bolted to body, epecially the ones that concerns the headlights.

Try additional grounding cables if necessary.
Was this
answer
helpful?
Yes
No
Tuesday, March 16th, 2010 AT 1:02 PM

Please login or register to post a reply.

Sponsored links