1999 Mitsubishi Eclipse shudering

Tiny
ANDYHI
  • MEMBER
  • 1999 MITSUBISHI ECLIPSE
  • 4 CYL
  • 2WD
  • MANUAL
  • 90,000 MILES
I recently replaced my motor and transmission with used parts from a wrecking yard the car starts fine and idles good around 1000 rpm my problem is that when you are in gear any gear and you let the revs down to 1000 to 1500 to car starts to shudder, like the shudder you get if say you were in 4th gear doing only 10km /hour the car jerks forward even if im doing 40km/hr and I put it in 5th but once I get the revs up it shifts fine, I have to drive it hard all the time and shift at 4000 or more to shift smoothly, my mechanic said to change the mass air sensor which I believe my car is not equiped with its a gs model please help
Do you
have the same problem?
Yes
No
Friday, July 4th, 2008 AT 9:49 PM

3 Replies

Tiny
KHLOW2008
  • EXPERT
Hi andyhi,

Did you check the plugs and it related parts?

Is the check engine light showing?

Check the EGR.
Was this
answer
helpful?
Yes
No
Saturday, July 5th, 2008 AT 10:11 AM
Tiny
ANDYHI
  • MEMBER
Yes I checked the plugs and changed the air filter cleaned out the throttle body, I will try replacing the egr valve next thank you
Was this
answer
helpful?
Yes
No
Saturday, July 5th, 2008 AT 6:58 PM
Tiny
KHLOW2008
  • EXPERT
Hi andyhi,

Don't replace the EGR valve first.

Just pull out the vacumn hose and block it and test again.
Was this
answer
helpful?
Yes
No
Saturday, July 5th, 2008 AT 9:13 PM

Please login or register to post a reply.

Recommended Guides