IDLE SITTING, GIVEN GAS

1997 Mitsubishi Eclipse

Tiny

JRW1986

August, 18, 2008 AT 2:29 AM

1997 4 cyl Two Wheel Drive Automatic 150000 miles

My question is: When I start my car and it's running idle in P park, It's like my car is barley staying on, it gets really weak and the rpm's are lower than normal I press the gas pedal to give it some gas to keep the rpm's at least above 2 so it won't turn off on me, on some occasions when my car is in D drive and I stop at a red light or stop sign my car completely shuts off on me and I have to turn the key to start the car all over again, do you guys know what the problem is?

Also theres another problem, my car is not reacting to the gas pedal, when I press the gas pedal just slightly to move about 25, 30mph it doesn't do a thing, it does a lot of putt putt putt putting, I have to press the gas pedal all the way down meaning I have to FLOOR IT just to move 25, 30mph, but eventually after about 10 times of flooring it finally it catches up with itself and acts properly, but when I turn the car off and turn it back on to use the car again that process starts all over again, that means more flooring it and putt putt putting know what the problem is?

FOUND 2975 RELATED QUESTIONS

6 Answers

Tiny

Jack42

August, 18, 2008 AT 7:43 AM

Helps to know what Make, Model, Year we are talking about here. Has any work ever been done on the car?Tune up? Any check engine light? If so have it scanned for the codes, this will give a starting point

Tiny

JRW1986

August, 18, 2008 AT 12:55 PM

Yes work has been done to my car, about 3 months ago I got my old transmission taken out and replaced with a new one. I never got a tune since I had the car. My last engine light check was two weeks ago, the codes that showed was saying something about; EGR, and SENSOR connected to my exhaust down pipe.

Tiny

Jack42

August, 18, 2008 AT 1:28 PM

Start with a tune up, then you will need to address the EGR problem. If the EGR hangs up ar th evalve doesnt seal all the way it can make th ecar misfire and hesitate at low speed. Still dont know what Make, Model or year car we are dealing with here

Tiny

JRW1986

August, 18, 2008 AT 1:57 PM

Oh sorry the car is a 1997 mitsubishi eclipse 4cyl 150,000mil non turbo.

Tiny

Jack42

August, 18, 2008 AT 3:03 PM

Also might want to clean out the throttle bore with carb cleaner and a rag. Thsi will help stabilize the idle

Tiny

JRW1986

August, 18, 2008 AT 11:58 PM

I went and got the engine light checked today and a number of things showed up, it said " ignition system fault-spark plug(s), vacuum leak on engine, high or low fuel pressure, dirty throttle body, IAC motor defective, poor electrical connection to the IAC valve, oxygen sensor defective, can you help me by explaining these problems to me?

Please login or register to post a reply.

Code Read Retrieval/Clear Mercedes Benz
Read Codes Like a Pro
Code Read Retrieval/Clear
Code Read Retrieval/Clear Scion XD
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear - Dodge Stratus
Code Read Retrieval/Clear Chevrolet Camaro